cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Task Reminder 'Null' Error

I am trying to create a flow that sends one email of all tasks to the user based off of the tasks assigned to them in a list.  I have followed several examples, but every time I get a 'null' error when trying to append to the array.  I have provided a link to one of the guides I have been following.  Any insight as to why I am getting this error is greatly appreciated.
 
InvalidTemplate. Unable to process template language expressions in action 'Append_to_array_variable' inputs at line '1' and column '2791': 'The template language function 'first' expects its parameter be an array or a string. The provided value is of type 'Null'. Please see https://aka.ms/logicexpressions#first for usage details.'.
 
 
Thank you for helping.
 
Flow OverviewFlow OverviewFlow pt1Flow pt1Flow pt2Flow pt2Flow pt3Flow pt3Flow pt4Flow pt4Flow pt5Flow pt5
1 ACCEPTED SOLUTION

Accepted Solutions
Anonymous
Not applicable

I figured out the issue.  For some reason, it wouldn't recognize the Assigned To column without accounting for the space.

 

So I needed to use ['Assigned_x0020_To'] instead of ['AssignedTo']

View solution in original post

5 REPLIES 5
RobElliott
Super User
Super User

Hi @Anonymous it would help is to identify the solution f you could post a screenshot of your flow. Thanks.

Rob
Los Gallardos

Anonymous
Not applicable

Hi @RobElliott, sorry about that. I've updated my post.  Thank you for the help. 

Hi @Anonymous,

 

According to the error information, the provide value is null, so maybe some items' "Assigned to" column are blank.

Could you share the setting of the "Assigned to" column in SharePoint?

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Anonymous
Not applicable

Hi @v-litu-msft, I have added an image of the list and 'assigned to' column settings.  Thank you for the help.

 

List.png

 

 

Anonymous
Not applicable

I figured out the issue.  For some reason, it wouldn't recognize the Assigned To column without accounting for the space.

 

So I needed to use ['Assigned_x0020_To'] instead of ['AssignedTo']

Helpful resources

Announcements
MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Power automate tips 768x460 v2.png

Restore a Deleted Flow

Did you know that you could restore a deleted flow? Check out this helpful article.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

Users online (2,189)