cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

Taxonomy Field Breaking Flow

Hello all, 


I am having problems with creating a Flow for SharePoint. 

 

We've had an array of errors, all pointing to a taxonomy field. To try and remedy this, in the advance section of "get item", we added a view which only showed ID and Title. When the view was applied, we tried again and still had no luck. This all breaks on the trigger (when item created/modified).

 

The Flow would try to run, but above the execution list, we get "Unable to check for new events'. Clicking this produces errors such as the one below: 

 

"error": {

"code": 502,
"source": "flow-apim-europe-001-francecentral-01.azure-apim.net",
"clientRequestId": "93592c8e-70ee-47f1-a04d-88bbfc38a11e",
"message": "BadGateway",
"innerError": {
"status": 500,
"message": "Future Proofing|0dd5f3c6-f9b4-427e-84b7-33a10f15a457\r\nclientRequestId: 93592c8e-70ee-47f1-a04d-88bbfc38a11e\r\nserviceRequestId: 0332c99e-9066-8000-9796-7a7076857fbf"
}
 
I've looked online and had no such luck. The taxonomy field seems to pick and choose which piece of metadata it breaks on. 
 
Any help or advice on how to fix this would be really appreciated. 
 
Many thanks
Kelly
9 REPLIES 9
Highlighted
Community Support
Community Support

Hi @Anonymous ,

 

Could you share a screenshot of your flow configuration? It seems that you have a Managed metadata column in the list.

 

I have created a list with a Managed metadata column, then start the flow with the trigger When an item is created or modified.

 

However, the flow is working properly when an item is created or modified.

 

Please share more details on your flow to help reproduce this issue.

1.PNG2.PNG

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Anonymous
Not applicable

Hi @v-yamao-msft ,

 

See below for my configuration of my workflow. Please tell me if this is not what you wanted to see and whether or not you want me to expand anything. 

I created a view without the managed metadata field but it still keeps breaking. 

If it's too small, I will upload in smaller parts.

 

Capture.PNG

 

Please let me know if you need any more information for me. 

 

Kelly

Highlighted
Anonymous
Not applicable

bump

Highlighted
Anonymous
Not applicable

Not sure I am allowed to bump, but going to do so because I seem to have dropped off front page and very quickly.

Highlighted
Anonymous
Not applicable

bump

Highlighted

Hi @Anonymous ,

 

Does your flow fail on the trigger when the list contains a Texonomy field?

Will it work with a list which doesn’t contain a Texonomy field?

I have made another several tests, however, all the flows work though a Managed metadata field is included in the list.

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted

I am having this same issue. 

 

There's a problem with the flow's trigger. See Details to fix the issue.

and then I click on details to see:
{

"error": {
"code": 502,
"source": "flow-apim-msmanaged-na-northcentralus-01.azure-apim.net",
"clientRequestId": "8244ffd4-4db7-471d-9086-88656c922f07",
"message": "BadGateway",
"innerError": {
"status": 500,
"message": "#Senegal|e7ede98e-035e-41dc-b497-9ccd8e01f8c7\r\nclientRequestId: 8244ffd4-4db7-471d-9086-88656c922f07\r\nserviceRequestId: 143adc9e-70b1-8000-4e3a-12d72104607f"
}
}
}
 

On a sharepoint list with managed metadata columns.

Trigger: When an item is created or modified.

 

It was all working for a while after many successful executions but eventually failes. 

 

When I copy by "Save As" the flow to a new flow, it all works, but then eventually fails.

 

Is this a data issue with the term set? Is this a bug with Flow?

 

Really need prompt help and suggestions.

 

@v-yamao-msft @Anonymous @thastark 

Highlighted

In addition to my last reply, I also see in the flow analytics - Error page

{

  "error": {

    "code": 429,

    "source": "flow-apim-msmanaged-na-northcentralus-01.azure-apim.net",

    "clientRequestId": "14b100ff-44c2-47cd-bfbd-9e93bf15d3d1",

    "message": "The response is not in a JSON format.",

    "innerError": "429 TOO MANY REQUESTS"

  }

}

Highlighted

I am also getting same error, any one find solution for this?

 

I have created automated flow which trigger when any item is crated in list.

My list has managed metadata field.

I am adding list item with custom code. i have checked my code, there is no any issue and list items is also created properly without any error.

 

But my flow goes fail and shows error of term store.

 

Any help would be appreaciated.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Top Solution Authors
Top Kudoed Authors
Users online (8,511)