cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
LOldfield
Regular Visitor

Team Flows not appearing in Team Flows, Microsoft Teams

I've been trying to set up a Team Flow in microsoft teams but I'm having no luck - my process is:

 

  1. Create a new team and add participants
  2. Create a new tab, install and add Microsoft Flows
  3. Hit create from blank:
  4. image.png
  5. Create a very basic scheduled email flow (Schedule every 1 day, Outlook Send Email V1, addressed to myself)
  6. Hit save

I reload the tab and I'm taken back to the "Create your first flow" page, reloading or navigating back to the page has the same result, I can never see the saved flow from within Teams

If I check flows.microsoft.com the flow exists under my team flows tab. Checking the share permissions reveals that the Teams sharepoint group is an owner. Nobody in else in the team can see it in theirs though. It's worth noting that this works for some Teams and not for others. 

12 REPLIES 12
v-bacao-msft
Community Support
Community Support

Hi @LOldfield ,

 

You need to install Flow into the specified Team.

Please check the following image:

78900.gif

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks Barry, 


I'd tried that before as well to no avail, I believe it's actually the same install process as just adding it through the tab menu. 

 

It yields the same result, the beginning screen with no associated flows. 

 

Cheers. 

Yes I've tried several several different ways. THEY DON'T SHOW UP, PERIOD!

 

I'm in the Team / Flow tab. Miraculously there's lots of templates. Cool, create and go back to list. "You have no flows"???? Actually I do, they're all listed in Flow. 

 

So essentially. Teams sucks? That's my experience. thus far. If you're in the tab and create a flow, intuition dictates it should be successful . However, ONCE AGAIN, we're talking Microsoft, so there you go.

 

Ill uninstall this ridiculous unintuitively run app.

 

 

@CW, I'm facing the same issue. Have you every found a solution? Thanks.

Hi colonel.

No not that I'm aware. I got fed up with that nonsense so deleted it all together. Nothing seems to work, in fact I've got history saying this for years and years.

Even trying to respond to you failed (surprise). This my second attempt which also always seems to happen. So much so that I forgot to do my typical backup: copy my response so WHEN it fails I paste them try to submit.

Bump.

Its one year later and I still have this problem. Cannot resolve with the above suggestions.

LOldfield
Regular Visitor

You know it's bad when you come back to the issue a year later and the only search result is your own forum post. 

 

Is there seriously not a solution for this yet? We need to centralise these and get them out of individual user profiles. 

 

 

LOldfield LOLOL
99lives
New Member

I've figured it out folks, at least this worked for me.

You have to be a Member of the Team, just being Owner Is not enough.

Being Owner but not Member has caused issues with other stuff in Teams in the past, because I'm guessing that in some cases on the backend Microsoft only checks if you are a Member, but doesn't check if you are an Owner.

 

Through the MS365 Admin Centre I gave myself both Owner and Member status of a Team, and after a few hours, the Flows in the Team appeared when they previously did not.

 

This solution worked for me, but this is still a really stupid bug that MS needs to fix. Owner means OWNER. An Owner should have access to EVERYTHING in a Team.

LOldfield
Regular Visitor

I think some change has been made here, as I was able to do this but only by installing the Power Automate tab into the "General" channel. Doing it outside of this didn't work. Still crappy and confusing as I'd rather these flows were contained in their own channel & tabs with documentation but better than nothing I suppose?

LilC
New Member

Playing around in my tenant this evening...

1. As an Owner or Member

2. In General or any other public channel

3. Not in private channels (the flow list looks to continue to try to refresh, but everything else is there)

 

...then I began to wonder why there wasn't an import button of some kind. Working on flows separately then sharing with the team in MS Teams...

1. Found this thread - Power Automate flows importing in Teams

 

...it will take time to populate in the team/channel, but it will show up!

The reason why I searched for these two topics, is b/c this will help a specific use case that will utilize a combination of Instant and Triggered flows. 

1. Triggered flows will camp

2. Instant flows are available to Run by all members of team/channel.

dorenit
Regular Visitor

I have similar problem. I was trying to "move" the power automate tab from the General channel to a private channel. 

When I am in a "normal" mode, all flows are refreshing infinite but when I popped out the tab window they appeared. 

Now I will delete the power automate tab in the general channel to see what will happen. 

Helpful resources

Announcements
MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

PWREduCon768x460.png

Join us at PWR EduCon - A Power Platform Conference

Learn from the top Power BI, Power Apps, Power Automate & Power Virtual Agents experts!

Power automate tips 768x460 v2.png

Restore a Deleted Flow

Did you know that you could restore a deleted flow? Check out this helpful article.

Users online (3,125)