cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
DavidLozzi
Level: Powered On

Teams: Failed to parse MS Graph backend response for request GetUserGroupsRequest

Trying to post an update to my Team. When I select the Team Id dropdown, i get the error

 

Could not retrieve values. { "error": { "code": "GeneralException", "message": "Failed to parse MS Graph backend response for request GetUserGroupsRequest. Request Url: https://graph.microsoft.com/edu/me/memberOf/$/microsoft.graph.group?$filter=groupTypes/any(c:c+eq+'U..., Request Method: GET. The response is invalid, cannot convert to type IList`1Error converting value {null} to type 'System.DateTime'. Path 'value[0].renewedDateTime', line 1, position 1935.", "innerError": { "request-id": "4c51a1fd-c1db-4cb8-945d-a3252870a0b8", "date": "2017-11-10T13:23:58" } } }
image.png

 

I tried entering the ID from the URL when I view the team in a browser, and that errored as well, GUID not valid. 

 
Lozzi
slalom
10 REPLIES 10
Super User
Super User

Re: Teams: Failed to parse MS Graph backend response for request GetUserGroupsRequest

@DavidLozzi

 

That's a funky one. I tried to replicate that on my tenant, and the error didn't come up. Not sure if browser cache might be a thing on the Flow site, but if it keeps happening, I see the need to open a support ticket with Microsoft.

 

Good luck. I hope you get this worked out.

 

Regards,

Fausto Capellan, Jr


Fausto Capellan, Jr


Did I answer your question? Mark my post as a solution! Did my response help? Please give it a thumbs up!

Proud to be a Flownaut!


Community Support Team
Community Support Team

Re: Teams: Failed to parse MS Graph backend response for request GetUserGroupsRequest

Hi @DavidLozzi,

 

I think there is some issue with your authentication of Microsoft Teams connector by clicking the Request Url that included in your error message.

I have made a test on my side and don’t have the issue that you mentioned. My flow’s configuration as below:8.JPGThe flow works successfully as below:9.JPG

 

Please check if your connection to Microsoft Teams connector is valid, if it is not, please update the connection.

Besides, please check if your account has access to Microsoft Teams connector.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
DavidLozzi
Level: Powered On

Re: Teams: Failed to parse MS Graph backend response for request GetUserGroupsRequest

I recreated the connection, still getting same error. What browser are you in? I'm in Chrome, tried IE last time, nothing worked.

Lozzi
slalom
Super User
Super User

Re: Teams: Failed to parse MS Graph backend response for request GetUserGroupsRequest

hi @DavidLozzi,

 

I tried on Google Chrome Version 56.0.2924.87 and IE 11, and it worked on both. Have you tried using a different workstation to see if you get the same behavior?

 

Regards,

Fausto Capellan, Jr


Fausto Capellan, Jr


Did I answer your question? Mark my post as a solution! Did my response help? Please give it a thumbs up!

Proud to be a Flownaut!


DavidLozzi
Level: Powered On

Re: Teams: Failed to parse MS Graph backend response for request GetUserGroupsRequest

I got excited as I tried another machine, same problem there 😞

 

 

it appears to be data related, could I have a team/group that's "stuck"?

Lozzi
slalom
Super User
Super User

Re: Teams: Failed to parse MS Graph backend response for request GetUserGroupsRequest

If that's the case, can you create a new team and add a couple of channels there to see if they surface in Flow?


Fausto Capellan, Jr


Did I answer your question? Mark my post as a solution! Did my response help? Please give it a thumbs up!

Proud to be a Flownaut!


DavidLozzi
Level: Powered On

Re: Teams: Failed to parse MS Graph backend response for request GetUserGroupsRequest

I am member of dozens of teams, one just got created as well, and it still errors. It's the listing of teams that's erroring, and I'm wondering if there are some early preview teams in here that maybe don't have the necessary data? Just a guess. I'll reach out to support.

Lozzi
slalom
Super User
Super User

Re: Teams: Failed to parse MS Graph backend response for request GetUserGroupsRequest

Yes, I agree that you should reach out to support. It's not like we're using SP on-prem where we can do most of the troubleshooting. Please let us know how that goes and if a solution is found.


Fausto Capellan, Jr


Did I answer your question? Mark my post as a solution! Did my response help? Please give it a thumbs up!

Proud to be a Flownaut!


Ski
Level: Power Up

Re: Teams: Failed to parse MS Graph backend response for request GetUserGroupsRequest

I am getting the same error when using the Microsoft Graph Explorer so my guess is they are having some issues on the backend..

sunilbotadra
Level: Power Up

Re: Teams: Failed to parse MS Graph backend response for request GetUserGroupsRequest

David, were you able to get this fixed? I am getting the same error on my teams and MS has no clue what it is!! Any info will help.

Helpful resources

Announcements
firstImage

Better Together Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

firstImage

Incoming: New and improved badges!

Look out for new contribution recognition badges coming SOON!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Community Summit North America

The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Top Kudoed Authors
Users online (7,818)