cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
dushyantb
Frequent Visitor

Teams - Post message as the Flow Bot not working

I want to post message on Teams when a new Task is created in Planner.

I am able to do that using a Flow, but the problem is, it posts as my own user.

 

For Teams action, I have two options:

  1. Post a message
  2. Post a message as the Flow bot to a channel

The second option keeps throwing 404 error.

 

{
  "error": {
    "code": "BotRequestFailed",
    "message": "Request to the Bot framework failed with error: '{\"error\":{\"code\":\"BadArgument\",\"message\":\"Unknown cloud 'in-client-ss.msg'\"}}'."
  }
}
1 ACCEPTED SOLUTION

Accepted Solutions
dblyth
Power Automate
Power Automate

@dushyantb The fix is fully deployed now. Anyone else hitting errors should share a flow URL. It is likely a different issue, and I can investigate.

 

View solution in original post

53 REPLIES 53
Yacob_hard
Advocate I
Advocate I

I have this same issue, except i'm shown a 403 error rather than 404...

{
"error": {
"code": "BotRequestFailed",
"message": "Request to the Bot framework failed with error: '{\"error\":{\"code\":\"ServiceError\",\"message\":\"Unknown\"}}'."
}
}
v-yamao-msft
Community Support
Community Support

Hi @dushyantb ,

 

Thanks for feedback.

The issue could be reproduced by me.

I will help report it and back to you later once I got any updates.

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Yacob, you will need to install the Flow app to your team for the bot to be able to post. This will be handled automatically later this week or earlier next week.

 

I'm still looking into the original report, which is something different. 

dblyth
Power Automate
Power Automate

@dushyantb I understand your issue now. It is limited to tenants in the India and UK regions. We'll get a fix for this out over the next week. 

kkreitzer
Frequent Visitor

I am experiencing this same issue and I am in a US region

dushyantb
Frequent Visitor

@dblyth will you please update us here once the issue is fixed?


@dblyth wrote:

@dushyantb I understand your issue now. It is limited to tenants in the India and UK regions. We'll get a fix for this out over the next week. 


 

Can you share some details? Flow URL?

@dushyantb The fix for this issue is checked in and a tentative ETA is next Wednesday for it to be available.

Dave4
Frequent Visitor

I have this problem as well in Australia. 

dblyth
Power Automate
Power Automate

@Dave4 please share your Flow URL so I can take a look, either here or email dblyth AT microsoft DOT com

dblyth
Power Automate
Power Automate

@dushyantb The fix is fully deployed now. Anyone else hitting errors should share a flow URL. It is likely a different issue, and I can investigate.

 

View solution in original post

Dave4
Frequent Visitor

This is working for me now. Thanks!

Just a question, what is the advantage of using the Flow bot rather than a functional user account that I create myself?
dblyth
Power Automate
Power Automate

Good to hear. 

 

Posting with the bot enables:

- @ Mentions (use the syntax: <at>UPN | email address | AAD object id</at>)

- Adaptive cards (Build your own at https://adaptivecards.io/ and use the "Post a generic adaptive card action")

- Minimizing (but not fully hiding) the identity of the user automating the process. 

dushyantb
Frequent Visitor


@dblyth wrote:

Good to hear. 

 

Posting with the bot enables:

- @ Mentions (use the syntax: <at>UPN | email address | AAD object id</at>)

- Adaptive cards (Build your own at https://adaptivecards.io/ and use the "Post a generic adaptive card action")

- Minimizing (but not fully hiding) the identity of the user automating the process. 


Actually, it highlights the identity. Its posting attaching a big ugly message with my name and email ID at the end of every message.

We are still refining the styling. That being said the original identity will always be part of the message as a mitigation against spoofing, spamming, etc. -- who set up the Flow will always be visible. 

Could it be either much smaller and styled so it looks like a footer, or, could it exist as hover text on a standard footer link?

We've made some styling tweaks that should roll out over the next week. Once Teams supports @ mentions within cards we'll move to an adaptive card to make a better styled footer. We're limited right now by the basic styling support offered by the APIs.

Hello,

 

I am facing multiple issues. I have shared my flow URL over email.

 

Error 1: The request failed. Error code: 'FailedToGetUserConversationId'. Error Message: 'Failed to find the user conversation id with error {"error":{"code":"ServiceError","message":"Unknown"}} for tenantId OurTenantId, userId {OmittedUserID}:orgid:{OmittedOrgID}, region emea, statusCode 429.'.

 

Error 2 - 429. The request failed. Error code: 'BotRequestFailed'. Error Message: 'Request to the Bot framework failed with error: '{"error":{"code":"ServiceError","message":"Unknown"}}'.'.

 

dneduva
New Member

Have been using flows for a few weeks now and especially the Post a message as Flow Bot to User task. It has always worked up until this point for all of the users in my organization. Suddenly today I started receiveing this error..
 
"error": {
"code": "BotRequestFailed",
"message": "Request to the Bot framework failed with error: '{\"error\":{\"code\":\"BotDisabledByAdmin\",\"message\":\"The tenant admin disabled this bot\"}}'."
}
 
What may be the cause of this?

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Users online (24,495)