cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

Re: Teams - Post message as the Flow Bot not working

me too

 

Request to the Bot framework failed with error: '{"error":{"code":"BotDisabledByAdmin","message":"The tenant admin disabled this bot"}}'.

Highlighted
New Member

Re: Teams - Post message as the Flow Bot not working

Same here, everythign worked last week.

 

{
  "error": {
    "code": "BotRequestFailed",
    "message": "Request to the Bot framework failed with error: '{\"error\":{\"code\":\"BotDisabledByAdmin\",\"message\":\"The tenant admin disabled this bot\"}}'."
  }
}
Highlighted
New Member

Re: Teams - Post message as the Flow Bot not working

Same Here

Worked fine on Aug 31st but broken on Sept 1st with no chnages made

 

Forbidden. The request failed. Error code: 'BotRequestFailed'. Error Message: 'Request to the Bot framework failed with error: '{"error":{"code":"BotDisabledByAdmin","message":"The tenant admin disabled this bot"}}'.'.

Highlighted
Regular Visitor

Same Here, Request to the Bot framework failed with error: '{\"error\":{\"code\":\"BotDisabledByAdmin\",\"message\":\"The tenant admin disabled this bot\"

Everything was working fine. No Changes made.

 

Today get the following error:

 

Request to the Bot framework failed with error: '{\"error\":{\"code\":\"BotDisabledByAdmin\",\"message\":\"The tenant admin disabled this bot\"



Highlighted
Power Automate
Power Automate

Re: Same Here, Request to the Bot framework failed with error: '{\"error\":{\"code\":\"BotDisabledByAdmin\",\"message\":\"The tenant admin disabled this bot\"

We have escalated this to the Teams/Bot API owners, as these errors are coming from the Bot Framework when we attempt to post. We will post an update here once we have more information
Highlighted
New Member

Re: Same Here, Request to the Bot framework failed with error: '{\"error\":{\"code\":\"BotDisabledByAdmin\",\"message\":\"The tenant admin disabled this bot\"

Any update on this? We facilitate some standup type of meetings with this specific setup and they've been failing since Friday.

Highlighted
New Member

Re: Teams - Post message as the Flow Bot not working

We too are having the same issue. Starting Friday 8/30/19 to present. 

 

Error:

Request to the Bot framework failed with error: '{"error":{"code":"BotDisabledByAdmin","message":"The tenant admin disabled this bot"}}'.

Highlighted
Power Automate
Power Automate

Re: Teams - Post message as the Flow Bot not working

Teams developers are currently investigating the issue. I'll post back here when they have an update. 

Highlighted
Power Automate
Power Automate

Re: Teams - Post message as the Flow Bot not working

Teams has identified the issue and is working on a mitigation now.

Highlighted
Power Automate
Power Automate

Re: Teams - Post message as the Flow Bot not working

According to their oncalls, the fix has mostly rolled out already, and should be done by this evening.

Highlighted
Power Automate
Power Automate

Re: Teams - Post message as the Flow Bot not working

We monitored this overnight and the problem appears to have been fully resolved. Please let me know if anyone is still seeing this where you *really* don't expect it to be blocked by an admin.

Highlighted
Frequent Visitor

Re: Teams - Post message as the Flow Bot not working

Hi,

 

I've tried today to use the Post a message as the Flow bot to a channel action and I am getting the same error:

 

Request to the Bot framework failed with error: '{"error":{"code":"BotDisabledByAdmin","message":"The tenant admin disabled this bot"}}'.

 

Can you advise on what was done to rollout the fix?


@dblyth wrote:

We monitored this overnight and the problem appears to have been fully resolved. Please let me know if anyone is still seeing this where you *really* don't expect it to be blocked by an admin.


 

Highlighted
New Member

Re: Teams - Post message as the Flow Bot not working

I'm getting mixed results I have a flow with 5 different routes. all same bot it just works on of the scenarios.

 

The other scenarios they fail

 

Here is the Fail Message.

 

{
"error": {
"code": "InvalidJsonInBotAdaptiveCard",
"message": "Microsoft.Azure.ProcessSimple.Data.Entities.Exceptions.ProcessSimpleDataException: The specified Teams flowbot adaptive card request is missing or invalid. The tracking Id is '{0}'. ---> Newtonsoft.Json.JsonReaderException: Unexpected character encountered while parsing value: P. Path '', line 0, position 0.\r\n at Newtonsoft.Json.JsonTextReader.ParseValue()\r\n at Newtonsoft.Json.Linq.JObject.Load(JsonReader reader, JsonLoadSettings settings)\r\n at Newtonsoft.Json.Linq.JObject.Parse(String json, JsonLoadSettings settings)\r\n at Microsoft.Azure.ProcessSimple.Data.Components.AdaptiveCards.AdaptiveCardBuilder.DeserializeAdaptiveCard(String serializedAdaptiveCard, RequestIdentity requestor) in X:\\bt\\1029746\\repo\\src\\processsimple\\Roles\\ProcessSimple.Data\\Components\\AdaptiveCards\\AdaptiveCardBuilder.cs:line 391\r\n --- End of inner exception stack trace ---\r\n at Microsoft.Azure.ProcessSimple.Data.Components.AdaptiveCards.AdaptiveCardBuilder.DeserializeAdaptiveCard(String serializedAdaptiveCard, RequestIdentity requestor) in X:\\bt\\1029746\\repo\\src\\processsimple\\Roles\\ProcessSimple.Data\\Components\\AdaptiveCards\\AdaptiveCardBuilder.cs:line 395\r\n at Microsoft.Azure.ProcessSimple.Web.Common.Validation.BotAdaptiveCard(String card, RequestIdentity senderRequestIdentity) in X:\\bt\\1029746\\repo\\src\\processsimple\\Roles\\ProcessSimple.Web\\Common\\Validation\\BotValidation.cs:line 585"
}
}
Highlighted
New Member

Re: Teams - Post message as the Flow Bot not working

I have a Power Automate workflow with posting the result to Teams via a Bot and it worked perfectly until right now. I get the same error message like the others:

 

"body":{"error":{"code":"BotRequestFailed","message":"Request to the Bot framework failed with error: '{\"error\":{\"code\":\"BotDisabledByAdmin\",\"message\":\"The tenant admin disabled this bot\"}}'."}}
Highlighted
Power Automate
Power Automate

Re: Teams - Post message as the Flow Bot not working

Teams app policies are described here, though access to the settings may require a tenant administrator:

https://docs.microsoft.com/en-us/MicrosoftTeams/teams-app-permission-policies

Highlighted
New Member

Re: Teams - Post message as the Flow Bot not working

Why would this have to do anything with the App Permission Policies?

Thanks in advance.

Highlighted
Power Automate
Power Automate

Re: Teams - Post message as the Flow Bot not working

Apps and bots are tied together on the Teams platform. So there's a teams app underlying the Flow bot that lets it post messages to users. If apps (or the Flow app) is blocked by policy, the Flow bot actions will fail with this error.

Highlighted
Helper II
Helper II

Re: Teams - Post message as the Flow Bot not working

@dblyth Can you please tell me that what are the differences between 1. Post a message (V3) and 2. Post a message as the Flow bot to a channel Also which option will be better to use in which situation? Thanks, Mamun
Highlighted
Power Automate
Power Automate

Re: Teams - Post message as the Flow Bot not working

"Post Message" sends as yourself, and you have full flexibility with an HTML editor to post styled messages, and @ mention users with <at>user@contoso.com</at> syntax. You can also reply to messages with this action. 

 

Posting as the Flow bot lets you send custom adaptive cards as the Flow bot identity. Adaptive cards can't currently @ mention users, though this is something we are working with Teams on. 

Highlighted
Frequent Visitor

Re: Teams - Post message as the Flow Bot not working

I am getting the same error message today (27/04/2020), I have tested this on two separate tenants and get the same error message. 

 

Did anyone ever figure out what this issue is? 

Helpful resources

Announcements
FirstImage

Microsoft Ignite 2020

Check out the announcement of Power Platform content at Microsoft Ignite!

thirdImage

Experience what's new for Power Automate

Join us for an in-depth look at the new Power Automate features and capabilities at the free Microsoft Business Applications Launch Event.

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (8,197)