cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Teams - Post message as the Flow Bot not working

I want to post message on Teams when a new Task is created in Planner.

I am able to do that using a Flow, but the problem is, it posts as my own user.

 

For Teams action, I have two options:

  1. Post a message
  2. Post a message as the Flow bot to a channel

The second option keeps throwing 404 error.

 

{
  "error": {
    "code": "BotRequestFailed",
    "message": "Request to the Bot framework failed with error: '{\"error\":{\"code\":\"BadArgument\",\"message\":\"Unknown cloud 'in-client-ss.msg'\"}}'."
  }
}
52 REPLIES 52
Highlighted
Frequent Visitor

Hi ,

 

sometimes , not always , I have this problem : {"error":{"code":"BotDisabledByAdmin","message":"The tenant admin disabled this bot"}}'.'.

Have you an idea ?

Tahnks

Giorgio

Highlighted

I am also getting the same error message today (27/04/20). Overnight no changes made. Does anyone know where it would even be possible to disable the flow bot as admin?

Highlighted

This is typically customer config-driven, but given the 3 reports this morning we have opened an investigation with the Bot Framework team to understand what is happening.

Highlighted

Looks like this was a transient outage in Teams / Bot Framework last night primarily impacting Europe. The issue appears to have been fully resolved as of about 3 hours ago.

 

Like I mentioned before, this is *typically* caused by customer config (app allow/block lists) preventing the Flow bot from interacting with Teams.

Highlighted

Thanks @dblyth for investigating however, I still have the same issue. I will test again first thing in the morning and hope it has been resolved. 

Highlighted

There's a fairly low volume of these at all times due to tenants that have the Teams app policies set to block the Flow / Power Automate app, which are documented here: https://docs.microsoft.com/en-us/microsoftteams/teams-app-permission-policies

 

If you are still seeing this tomorrow feel free to message me separately and I can probably take a look.

Highlighted

I have cross verified the teams admin center and all the option are open. Still we are getting the following message

 

Error Code: BotDisabledByAdmin, Error Message: The tenant admin disabled this bot, Status Code: Forbidden, ReasonPhrase: Forbidden

 

Any update on this!!

Highlighted

All -- I can't investigate anything with out actual flow / environment / tenant details. If you don't want to share, you need to email me. Same alias @ microsoft.com

Highlighted

At the moment work fine ,

Thanks

 

Highlighted

Hi, as I am developing a flow in my test tenant, prior to shipping this to our actual tenant, I do not seem to see the result of the flow appearing in my Teams channel. Posting as the user associated with the connection in flow seems to work. Are we experiencing problems in the back end again? Or am I doing something wrong? Policies in my tenant allow all apps to be run, flow app is setup in the Teams site as a bot.

Highlighted

And offcourse I forgot to check the obvious... Status of the flow was set to "Off".... Sorry for the confusion!

Highlighted
Frequent Visitor

Received this error today

 

Request to the Bot framework failed with error: '{"error":{"code":"BotDisabledByAdmin","message":"The tenant admin disabled this bot"}}'.

 

Is this related to the current issues with Teams?

 

@dblyth 

Highlighted

@hcristiano there are no known issues with Teams currently that would cause this.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Top Solution Authors
Top Kudoed Authors
Users online (7,402)