cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper II
Helper II

Teams creation through Power Automate not creating General folder

Hi

 

After a few other issues, I had the teams creator connector is now working, one issue i have discovered though is that the General folder that is normally created when a new team is created is now not created until you open the file tab inside team and you have to repeat this twice, firstly you open the files tab and get an error message that the files cant be located at the moment, you then go back to the posts tab, and then back to files and it loads, at this point, in the sharepoint site the General folder appears and shows it being created by the user that opened the files tab. This doesnt seem to be working as intended as the General folder is normally linked to the General channel. Any ideas? 

4 REPLIES 4
Highlighted
Super User II
Super User II

Hello @mousman85 

Which version of Teams are you using? Desktop App or Web App? I've been able to reproduce your steps, and it's true that at first the files tab is not available, but when I change the tab and go back again it is. So I think it should be someting of a backgound process or a refresh issue.

Hope it helps!
Ferran

Did I answer your question? Please consider to mark my post as a solution to help others.
Proud to be a Flownaut!
Highlighted

Hi,

 

Yes so both desktop and web version of teams has this issue. The problem arises as when you try to populate the General folder automatically using flow, i.e create new folder in General, that General folder cannot be found as it is not created. I put a delay in to see if it was a delay issue, but this still didn't fix. 

 

My current work around is that I have the Flow create a General folder first, and populate this with the folders I need for each team created. 


Then when a user goes into teams then click files, they get the same error we have that the files cannot be found, but upon going back into the files tab the files are there and so are the newly created ones. From a user experience its not ideal as we've had to communicate out that there is an issue with this at the moment, but this is the only work around I can see.

 

I have even tried sending a message to the team before template folders are created but this doesn't create anything either. 

Highlighted

You are absolutely right... Maybe there's an issue with the action, which is currently in preview.

You could try to create the Team using other type of architecture, although it is much more complex, as this one: https://laurakokkarinen.com/provisioning-teams-with-a-site-design-flow-and-microsoft-graph/

 

Regards,

Ferran

Did I answer your question? Please consider to mark my post as a solution to help others.
Proud to be a Flownaut!
Highlighted

So that was my orignal way of creating a team i'd provision a group and then use a HTTP to put a team against that group ID, this was when i noticed the folder creation not working. 

 

It now also looks like this issues expands to all channels created with flow as well. I've just had excatly the same issue with a newly created team and new channel. Folder does not exsist until you open the files tab and go back into the files tab within teams, desktop or web, this seems like a large issue and i'm surprised its not getting more notice, as it basically means team and channel creation through flow is broken to a point. 

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Top Solution Authors
Top Kudoed Authors
Users online (8,693)