cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MichelH
Advocate V
Advocate V

Teams trigger 'When I m mentioned in a Teams channel' is always stating: There's a problem with the flow's trigger. Fix the trigger

So in the editor I connect to teams using various accounts, (My own and service accounts, that I first made team member, so I can do the @TeamMember thing ) and then succesfully select a team and a channel.
I would think this means all is fine, as the account can see the team and the channels. right?
 
With my own account using a different flow I can even post messages to the channel !!  
 
But when I try to use the Teams trigger, it all seem fine until I save the flow.
Then almost instantly it decides that the trigger is bad.  😕
 
When I edit the flow it gives the following error:
{
  "error": {
    "code": "Forbidden",
    "message": "Forbidden",
    "innerError": {
      "request-id": "8484241e-1c0e-4bde-a5f6-f1200b7154fb",
      "date": "2019-08-27T13:59:58"
    }
  }
}


What could be wrong?

 

Thanks for any feedback,

 

Michel

 
1 ACCEPTED SOLUTION

Accepted Solutions
v-bacao-msft
Community Support
Community Support

 

Hi @MichelH ,

 

Please try doing the following and see if the error still exists:

  • Click Save as to create a copy of Flow, then turn on Flow and configure where it may need to be configured, and finally see if this copy is available.

55.PNG

  • Alternatively, you could export this Flow as a .zip file and re-import it as a new Flow. After doing the relevant configuration, check if similar problems still exist.

Hope it helps.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
v-bacao-msft
Community Support
Community Support

 

Hi @MichelH ,

 

Please try doing the following and see if the error still exists:

  • Click Save as to create a copy of Flow, then turn on Flow and configure where it may need to be configured, and finally see if this copy is available.

55.PNG

  • Alternatively, you could export this Flow as a .zip file and re-import it as a new Flow. After doing the relevant configuration, check if similar problems still exist.

Hope it helps.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

This is quite strange Barry, but your workaround works.

 

Thanks,

 

Michel

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Users online (2,801)