cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
iskias
Regular Visitor

Test connection keeps failing when trying to build flow with MS Forms

I have created a form and I am trying to set up a flow that sends me an email notification when it is submitted.


When setting up a flow the power automate app is giving a "Test connection failed" error when trying to connect to Forms.

Although the connections to both forms and outlook are there under Data>>Connections, when I try to build a new flow to trigger an email upon submitting a form, I get the error "Test connection failed. Details: Required user login". I am on a O365 personal subscription. I have tried multiple workarounds (e.g restablishing connections, etc) but with no luck.

 

iskias_0-1612783046352.png

 

iskias_1-1612783093207.png


When I even try to build it using the template "Send an email to responder when response submitted in Microsoft Forms" I get the following: (!)

 

Screenshot 2021-02-08 132248.jpg

 

Any ideas? Are O365 personal accounts not supposed to build such flows?

2 ACCEPTED SOLUTIONS

Accepted Solutions
v-duann-msft
Community Support
Community Support

Hi @iskias 

 

Thank you for posting.

 

According to your description and screenshot, I believe you don’t know the limitation of form.

 

For form connector used to connect flow with form, it only supports for organization account which means only works for O365 account. Thus, you personal account won't work.

v-duann-msft_0-1612935868403.png

 

https://docs.microsoft.com/en-us/connectors/microsoftforms/

 

Meanwhile, for outlook connector, you select incorrect outlook connector as well. You are using personal account which ends with outlook.com. Therefore, you should select ‘outlook.com’ as connector instead of ‘Office 365 account’ as below.

v-duann-msft_1-1612935868405.png

 

 

v-duann-msft_2-1612935868410.png

 

 

Hope the content above may help you.

 

Thanks

Anna

View solution in original post

Hi @iskias 

 

Thank you for your reply.

 

Yes, if you persist this functionality, please upgrade your account to business type using Office365 account. Then, your flow will be working fine.

 

Thanks

Anna

View solution in original post

3 REPLIES 3
v-duann-msft
Community Support
Community Support

Hi @iskias 

 

Thank you for posting.

 

According to your description and screenshot, I believe you don’t know the limitation of form.

 

For form connector used to connect flow with form, it only supports for organization account which means only works for O365 account. Thus, you personal account won't work.

v-duann-msft_0-1612935868403.png

 

https://docs.microsoft.com/en-us/connectors/microsoftforms/

 

Meanwhile, for outlook connector, you select incorrect outlook connector as well. You are using personal account which ends with outlook.com. Therefore, you should select ‘outlook.com’ as connector instead of ‘Office 365 account’ as below.

v-duann-msft_1-1612935868405.png

 

 

v-duann-msft_2-1612935868410.png

 

 

Hope the content above may help you.

 

Thanks

Anna

Anna, thanks a lot for the clarification! It's now clear to me why it wasn't working...

So, I guess I would have to upgrade my account to business if I want to use this functionality?

 

Regards,

Ioannis

Hi @iskias 

 

Thank you for your reply.

 

Yes, if you persist this functionality, please upgrade your account to business type using Office365 account. Then, your flow will be working fine.

 

Thanks

Anna

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Users online (2,992)