cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Baptiste_k97
Frequent Visitor

Transfer specific attachments from Outlook to Sharepoint

Hello,

 

I'm trying to create a flow to save my email attachments to a document library.

When I use the Power Automate template, all my attachments as well as pictures attached to the body of my email are transferred.

 

How can I filter the attachments to forward by content type? I would like to transfer any attachments which are PDF or PPT / PPTX.

 

thank you in advance for your help

Baptiste K.

1 ACCEPTED SOLUTION

Accepted Solutions
HimanshuSSharma
Resolver I
Resolver I

This is how I did a quick PoC for 'pptx' with Or condition:

HimanshuSSharma_0-1613405106004.png

Tested with 3 files: 1 xlsx, 1 png and 1 pptx and the result:

HimanshuSSharma_1-1613405255704.pngHimanshuSSharma_2-1613405278730.png

 

HimanshuSSharma_3-1613405327046.png

 

Can you share snapshots of the flow so we can take a closer look?

 

View solution in original post

5 REPLIES 5
HimanshuSSharma
Resolver I
Resolver I

You might be able to filter attachments using conditions where name contains (or ends with), and specify the extension there like ".pdf" or ".ppt"

I don't know which part to modify to take this condition into account.

I tried adding a condition that checks the extension of my attachment after the variable part. But without success.

All attachments from my email are transferred to the library (attachment and images of my signature).

 

HimanshuSSharma
Resolver I
Resolver I

This is how I did a quick PoC for 'pptx' with Or condition:

HimanshuSSharma_0-1613405106004.png

Tested with 3 files: 1 xlsx, 1 png and 1 pptx and the result:

HimanshuSSharma_1-1613405255704.pngHimanshuSSharma_2-1613405278730.png

 

HimanshuSSharma_3-1613405327046.png

 

Can you share snapshots of the flow so we can take a closer look?

 

View solution in original post

Hello HimanshuSSharma,

I created this automation using your example. Your opinion ?

It's the first time I'm doing this, I don't know if I forgot something ...

I performed a test and the procedure is working.

 

Step 1 :

 

step1_po.PNG

 

Step 2 :

 

step2_po.PNG

 

 

 

@Baptiste_k97 it looks okay to me, despite the language barrier.

Please accept the solution if you found it helpful!!

 

Thanks!

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Top Kudoed Authors
Users online (22,274)