cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Jhonny_Nassif
Regular Visitor

Trouble fetching the ID of an email sent by "Send email" action

Hello everyone!

 

It is my understanding that it is currently impossible to send emails directly from shared mailboxes though Power Automate. I saw many posts from people reporting that they couldnt get the "Send an email from a shared mailbox" action to work, and the solution revolved around settling with a workaround, that consists in using the "Send an email" action and Setting it to "send as" the shared mailbox, provided your account had the permissions required to do so.

 

Very well. Im fine with that.

 

The problem is that even though the action sends that email as the shared mailbox, the email is still generated in my personal sent box, and not in the shared email's. The flow Im building is supposed to run about 50 times per work day, each time generating an email, which means that on average, per week, im going to have around 250 emails in my sent box, all of which I didnt actually personally sent. That ammount of emails will certainly make it painful to manage the emails I actually send.

 

So I tried to fix this problem by adding some cleanup actions in the same flow, just after the email was sent. The plan was to identify the sent email and move it to a folder other than my sent box. I tried using the "Get email" action, but that straight up asks me for the email ID as the only way to fetch the email. Considering that the "Send email" action does not provide the sent email's ID in the dynamic content list, I figured i couldnt use that to make it happen. Moving on, I tried using the "Get emails" action, which I set up as follows:

 

Jhonny_Nassif_0-1614373563803.png

The issue Im having is that this action is timing out after running for about 10 to 15 minutes without sucessfully fetching the solo, recently sent email:

 

Jhonny_Nassif_0-1614374078974.png

 

The "Move email" action asks for the email ID and the destination folder. So I wonder: is there a way to make the "Send email" action output the ID of the email it just sent, allowing me to skip this fetching step? If not, what am I doing wrong with my "Get emails" action, and also, is there another way Im overlooking to get that sent email's ID?

 

Thanks in advance!

1 ACCEPTED SOLUTION

Accepted Solutions
v-duann-msft
Microsoft
Microsoft

Hi @Jhonny_Nassif 

 

Thank you for posting. Seems you posted duplicate requests, please refer below link for details.

Trouble fetching the ID of an email sent by the "S... - Power Platform Community (microsoft.com)

 

Thanks

Anna

View solution in original post

1 REPLY 1
v-duann-msft
Microsoft
Microsoft

Hi @Jhonny_Nassif 

 

Thank you for posting. Seems you posted duplicate requests, please refer below link for details.

Trouble fetching the ID of an email sent by the "S... - Power Platform Community (microsoft.com)

 

Thanks

Anna

View solution in original post

Helpful resources

Announcements
User Groups Public Preview

Join us for our User Group Public Preview!

Power Automate User Groups are coming! Make sure you’re among the first to know when user groups go live for public preview.

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Users online (44,022)