cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Trouble with modyfying condition created by me and loading control action from template.

Hi all,

 

I'm using ms flow in Office browser for few weeks. I have licenses: "Office 365 Business Premium" and "Microsoft flow free". I started with creating flom from ready template then I modified it (because i have in Polish language) and block diagram shows the below photo.

 

1.png

In the first condition named "Warunek" is from template, so after Approval action "Zapoznaj" I can value as "Response" and edit it in Advanced mode!!! But I have created new action in "If yes" block and the most important action in control action Use to each 2 named "Zastosuj od każdego 2". In that "light" are created 2 actions: Approval action "Sprawdzaj" then goes to Condition named "Warunek 2".

 

2.png

Then i cannot select values "Response" or eventually "Comments" as in Approval action "Zapoznaj". 

 

3.png

 

I'd like to copy that first condition by option "Copy to my clipboard". Then i try paste to after second Approval action "Sprawdzaj". but i get that error: "error while loading component" and i cannot open this condition.

 

I've searched any forums but i still have got no clue what should i do.

Why i cannot modify condition created by me? Is that possible to fix that error? Any ideas? Thx for any help.

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Dual Super User
Dual Super User

Re: Trouble with modyfying condition created by me and loading control action from template.

Which action are you specifically using?  

 

Are you using Start and Wait for an Approval or just Create Approval?  If you use Create Approval you also have to use a Wait for an Approval.  That's where the responses are.  The Start and Wait will also have those.  The create only has the dynamic data for creating the approval and nothing about responses.  It looks like you might be using the wrong action.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

View solution in original post

Highlighted
Community Support
Community Support

Re: Trouble with modyfying condition created by me and loading control action from template.

 

Hi @Prochotap ,

 

As mentioned in Pstork1, the Approval feature has been updated several times, and the use of the Approval action in your current template may not be suitable for the current situation.

You could refer to the following thread for using the Condition in the current approval action to determine the approval result. Select the appropriate configuration based on the Approval type.

https://powerusers.microsoft.com/t5/Building-Flows/Response-Dynamic-Content-for-Approvals-does-not-a...

 

About Responses Approver Response and Responses Comments, you could search for the Dynamic content you need directly in the search box.

Image reference:

50.PNG

Besides, please check this thread and see if it helps:

https://powerusers.microsoft.com/t5/Building-Flows/Creating-Approvals-using-quot-Start-and-wait-for-...

 

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

9 REPLIES 9
Highlighted
Dual Super User
Dual Super User

Re: Trouble with modyfying condition created by me and loading control action from template.

The real problem is based on the fact that you are using a template.  The Approval action has gone through several revisions and during those revisions the names of the dynamic content associated with them changes.  Some of the templates use the original Approval action.  But when you add new Approval actions you are getting the new action.  For the new Approval action the responses and comments are returned as a collection of reponses, even if there is only one approver.  But what used to be Response is now called Outcome.  If there is only one approver than Outcome will have either "Approve" or "Reject" in it.  That I think is what you are looking for.  I would recommend modifying the Flow to replace the original Approval action with the new one and using that throughout the Flow from now on.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
Highlighted
Frequent Visitor

Re: Trouble with modyfying condition created by me and loading control action from template.

Hello @Pstork1 

Thank you for answer, but i've just building the new flow from scratch after coming new file to SharePoint list and adding approval action in first condition i don't get it that values as 'Response' and 'Comments'. How that is possible? Thank you for reply.

 

Greetings.

 

 

Highlighted
Dual Super User
Dual Super User

Re: Trouble with modyfying condition created by me and loading control action from template.

As I said, you don't get Response and Comments as dynamic content with the new Approval Action.  YOu do get a Responses Approver Response and Responses Comments. When you use those it will automatically add a Loop to process the Responses collection.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
Highlighted
Frequent Visitor

Re: Trouble with modyfying condition created by me and loading control action from template.

I've just checked to the first condition by me but i don't get Responses Approver Response and Responses Comments. The rest of them are in below picture:

Approve.png

 

Highlighted
Dual Super User
Dual Super User

Re: Trouble with modyfying condition created by me and loading control action from template.

Which action are you specifically using?  

 

Are you using Start and Wait for an Approval or just Create Approval?  If you use Create Approval you also have to use a Wait for an Approval.  That's where the responses are.  The Start and Wait will also have those.  The create only has the dynamic data for creating the approval and nothing about responses.  It looks like you might be using the wrong action.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

View solution in original post

Highlighted
Super User
Super User

Re: Trouble with modyfying condition created by me and loading control action from template.

@Prochotap 

If the intent of your condition is to see if the item was approved, then you should be referencing Outcome and the value you are testing is Approve.

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott
Highlighted
Community Support
Community Support

Re: Trouble with modyfying condition created by me and loading control action from template.

 

Hi @Prochotap ,

 

As mentioned in Pstork1, the Approval feature has been updated several times, and the use of the Approval action in your current template may not be suitable for the current situation.

You could refer to the following thread for using the Condition in the current approval action to determine the approval result. Select the appropriate configuration based on the Approval type.

https://powerusers.microsoft.com/t5/Building-Flows/Response-Dynamic-Content-for-Approvals-does-not-a...

 

About Responses Approver Response and Responses Comments, you could search for the Dynamic content you need directly in the search box.

Image reference:

50.PNG

Besides, please check this thread and see if it helps:

https://powerusers.microsoft.com/t5/Building-Flows/Creating-Approvals-using-quot-Start-and-wait-for-...

 

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted
Frequent Visitor

Re: Trouble with modyfying condition created by me and loading control action from template.

Ok. I used  "Create Approval" but then i've just changed to "Start and Wait for an Approval" and solved my problem. Thank you for help!

Highlighted
Dual Super User
Dual Super User

Re: Trouble with modyfying condition created by me and loading control action from template.

You can use Create Approval, but only when you also use a Wait for Approval as the other half of the pair.  But its the wait portion that returns the responses.  That's why you didn't see them



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Helpful resources

Announcements
firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

Join the new Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (10,888)