cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mraath
Level: Power Up

Twitter not posting - Error from token exchange The connection is not found. Please create a new connection and change your application to use the new connection

HI there, I have created new flow in order to post instagram text (part thereof) to twitter.
All the steps pass when I test it, except the "Post a new tweet" part... It seems to not find a server or authentication token or something? I have disconnected and reconnected my twitter connector - still the same issue.

 

Status code
404
Headers
x-ms-failure-cause : apihub-token-exchange
x-ms-apihub-cached-response : false
Date : Wed, 03 Jul 2019 11:40:48 GMT
Content-Length : 390


Here is the Body of the error:

{
"status": 404,
"source": ...//power-te-northeurope-3.azurewebsites.net:443/tokens/europe-001/twitter/shared-twitter-f5f79f67-ca3b-44f8-b02e-544d1ec97cf1/exchange,
"message": "Error from token exchange: The connection (europe-001/twitter/shared-twitter-f5f79f67-ca3b-44f8-b02e-544d1ec97cf1) is not found. Please create new connection and change your application to use the new connection."
}
2 REPLIES 2
Super User
Super User

Re: Twitter not posting - Error from token exchange The connection is not found. Please create a new connection and change your application to use the new connection

@mraath 

Hi there.  Was it working previously?  I know most of the social media sites were having trouble today.

 

-Ed-

If this reply has answered your question or resolved your challenge, please consider marking it as a Solution. This helps other users find it more easily via search.

Community Support Team
Community Support Team

Re: Twitter not posting - Error from token exchange The connection is not found. Please create a new connection and change your application to use the new connection

Hi @mraath ,

 

I tested it on my side using Post a tweet, but there is no way to reproduce the issue you mentioned.

According to the error, it seems that you need to re-create the connection.

Please try to delete the tweet connection in the connection list and re-create the connection.

54.PNG

Then reconfigure a similar Flow, use the new connection and see if the issue still exists.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (4,821)