cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
moeboje
Level: Powered On

Typeform connector doesn't work?

Dear community,

 

Is there any problem with the typeform connector? Since yeaterday the connection failed. 

Its aslo not possible to make a new connection. Does anyone have the same problem?

 

Thanks!

 

Mario

37 REPLIES 37
akochanski
Level: Powered On

Re: Typeform connector doesn't work?

I am having the same issue. All of the connectors have failed, and I can't get them to reconnect

Community Support Team
Community Support Team

Re: Typeform connector doesn't work?

Hi @moeboje,

 

I have made a test on my side and don't have the issue that you mnetioned.

 

The Typeform connector works fine on my side.

 

I afraid that the connection for the Typeform connector is invalid on your side,please take a try to create a new connection to Typeform connector:

Capture.PNG

 

And please make sure the API Key for the connection is correct:

Capture.PNG

 

Best regards,

Alice

 

 

 

sdefesche
Level: Powered On

Re: Typeform connector doesn't work?

We are having a similar issue with the TypeForm connector.

It is possible to establish the connection, using the API key, but whereas previously it was possible to then make a selection from the available forms, that no longer works. 

Two days ago, it was then possible to enter the formID that Typeform uses, and that triggered the dynamic content from that forms to become available (partially: hidden fields and questions in question groups were no longer available).

 

As of today, the connection to TypeForm seems completely broken- using the formID does not work anymore and the trigger "When a response is submitted" is NOT activated when an actual response is submitted.

 

This means that ALL of the flows we have running using TypeForm as a trigger are now no longer working.

akochanski
Level: Powered On

Re: Typeform connector doesn't work?

I am having the same issue with my typeform connector 

lalder
Level: Powered On

Re: Typeform connector doesn't work?

We've been having this issue as well. The trigger has not been working since 07/31/18. We use it to gather customer satisfaction surveys. We've been testing in one location for 2 months and were going to roll out to the rest of the stores today... but now we have to wait for a solution to this problem.

spardy1981
Level: Powered On

Re: Typeform connector doesn't work?

For the past few days, we have this issue as well. The API and connection is there, but we are not able to get the form data from the flow.

akochanski
Level: Powered On

Re: Typeform connector doesn't work?

Alice, found this in a SQL Server forum 

 

"My org has been using Azure's Logic Apps for some time now. They have always worked fantastic. There is a built-in connector for Typeform (survey software.) Recently, as of 8/1/18, Typeform has changed their API from their Data API to their Responses API. This has unfortunately broken the connector, as my Logic App no longer can find the data. I reached out to Typeform initially, and this was their response:

"Our team have been in contact with Microsoft about this change and they were given time to prepare and move accounts over to the new API.  First, I would recommend re-authorizing your Typeform account with Azure and try again however if that still doesn't work then I'd recommend speaking with the Azure team to find out why your account isn't using the new API."

They recommended re-authorizing the API (didn't work.) Hopefully, someone on the Azure team sees this and has some sort of information."

Leon-Inspired
Level: Powered On

Re: Typeform connector doesn't work?

This is a major pain.

 

I was building out a fairly complex form that needs to go live and half the responses dont get picked up by the flow! Hopefully microsoft sort this out ASAP

sdefesche
Level: Powered On

Re: Typeform connector doesn't work?

Issue still unsolved. We have also contacted TypeForm support and they let us know they are working on it with Microsoft.
lalder
Level: Powered On

e this is resolvedRe: Typeform connector doesn't work?

I was told by my Microsoft contact last night that it will be at least another week before this is resolved.

mans
Level: Powered On

Re: Typeform connector doesn't work?

Hi,

 

I was finally able to use the connector again, however the way it works is not the same anymore.

 

Prior to the update I was able to get the list of answers as variables, being able to use them for conditions and to send content to other applications. 

 

Now, I only get a list of technical fields. Is there any way to fix this as all my Flows using Typeform are not usable anymore ?

 

Thanks

 

Typeform.PNG

 

 

spardy1981
Level: Powered On

Re: Typeform connector doesn't work?

Hi,

 

How do you even get the connection? I wasn't even able to get the form list.

 

Let me know how you do it.

 

Thanks

mans
Level: Powered On

Re: Typeform connector doesn't work?

Hi,

 

The only way I managed to get a connection was by creating a new flow, all my old flows are not working at all.

 

Even if I managed to get a connection it seems useless to me at this time, unless I am missing something..

 

Thanks

spardy1981
Level: Powered On

Re: Typeform connector doesn't work?

Thank you.

 

Indeed the new connectinon work, but I ran into the same issue as yours. I am not able to selet individual question. The is really painful.

jamest342
Level: Power Up

Re: Typeform connector doesn't work?

This post was actually mine. I'm not getting any further responses from Microsoft on this. Keep pushing them! I'm having to rely on the Google Sheets integration on Typeform.

charan_sodhi
Level: Powered On

Re: Typeform connector doesn't work?

Any luck with this? 

 

I got everything right, I even found a way to get the questions/answers through the "Response answer" technical field but the problem is that the flow never gets triggered, I deleted the old flow and created a new one but everytime I submit a response in typeforms, the flow doesn't trigger at all.

 

Did you hear anything from MS?

charan_sodhi
Level: Powered On

Re: Typeform connector doesn't work?

We are supposed to deliver this as a solution to our client in their production environment. This will be such a disaster. Smiley Sad

Leon-Inspired
Level: Powered On

Re: Typeform connector doesn't work?

We have a project pending this to go to production for a client now too! Was meant to be complete a couple weeks ago

charan_sodhi
Level: Powered On

Re: Typeform connector doesn't work?

This is what I'm getting when I submit the typeform, looks like this is an MS problem. 

 

2018-08-27 00_36_24-Run History _ Microsoft Flow.png{
  "error": {
    "code"502,
    "source""flow-apim-msmanaged-na-eastus2-01.azure-apim.net",
    "clientRequestId""1668d49e-34ef-4d63-96b0-1dcbdcd7d274",
    "message""BadGateway",
    "innerError": {
      "code""internal_error",
      "description""An unexpected error occurred (pq: could not access status of transaction 0)"
    }
  }
}

 

Can someone please help?

 

Thanks,

Charan

Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Watch the event on demand for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 Release Wave 2 Plan

Power Platform 2019 Release Wave 2 Plan

Features releasing from October 2019 through March 2020.

thirdimage

Flow Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Flow Community Video Gallery!

Top Kudoed Authors
Users Online
Currently online: 397 members 2,897 guests
Please welcome our newest community members: