cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Davidstout
New Member

Typeform sending values, Excel not receiving all of them.

Hello,

 

I'm new to this and I've got a problem with a flow that connects a typeform to an excel spreadsheet.

The type form has about 17 questions and I want to pull the answers into an excel spreadsheet (and then send an email to addresses entered into the spreadsheet from the typeform).

 

I've set up the flow and run a test. Type form is sending all the data as required (see output image below) but Excel isn't receiving all the data. It is however receiving some of it so you'll see under the headings 'Central Team' and 'Submission Date' it's getting data, but for any of the other questions it just has 'Null' even though typeform is sending it (see second image).

 

I imagine it's something painfully simple I'm doing wrong, so my apologies for being a fool! Any help would be greatly appreciated!

 
 

type out.png

 

excel in.png

 

1 ACCEPTED SOLUTION

Accepted Solutions
v-bacao-msft
Community Support
Community Support

 

Hi @Davidstout ,

 

The action in Excel connector cannot change the value output from Type form, please try to fill these Dynamic content in Compose and check if the value of these Dynamic content is null.

Maybe the dynamic content you choose is unexpected.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
ChristianAbata
Super User
Super User

hi @Davidstout  I recomend you to use ParseJson to get all the content of your output.

Please see this example of how to use parse json.

getformsImage.gif



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA
v-bacao-msft
Community Support
Community Support

 

Hi @Davidstout ,

 

The action in Excel connector cannot change the value output from Type form, please try to fill these Dynamic content in Compose and check if the value of these Dynamic content is null.

Maybe the dynamic content you choose is unexpected.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

@ChristianAbata your a life saver, this was driving me mad, I could see the Data coming over from TypeForm web hook, but like @Davidstout  it was not writing to excel (output on the excel write element was null)

 

With Parse Json put in the middle looking at the body of the TypeForm message worked 🙂

 

Microsoft need to look at the TypeForm to Excel template, as it does not saying anything about the ParseJson

 

 

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Users online (2,986)