cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted

UI Flow WebApp with Dynamics 365

Hi, 

I build a UI WebApp flow and recorded my steps with the Selenium IDE tool. 

So far so good. 

For one specific process, I have a problem. 

The problem is that I have to hit a 'run' button in a window. 

Once the run button is hit a new window will kind of slide in. 

It's not a pop out window (please see the screenprint below). 

The problem with this 'slide in window' (as I just call it) is that I have to hit the OK button to run the function. 

(I could also enter Alt+Enter)

Yet, the Selenium IDE tool does not seem to recognize the new window. 

As a result, my flow fails at the time the run button is hit. 

Does somebody have an idea how to overcome this problem?

Best regards, 

Ludwig

Step 1Step 1Step 2Step 2

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: UI Flow WebApp with Dynamics 365

Also got that one fixed. 

The problem was the execution speed. 

Once I slowed that down, things correctly loaded and the process completed successfully. 

Many thanks, 

Ludwig

View solution in original post

4 REPLIES 4
Highlighted
Community Support
Community Support

Re: UI Flow WebApp with Dynamics 365

Hi @lreinhard7,

 

Sorry, I never met this issue, could you please tell us what's the portal are you using? So I could have a try to reproduce it.

 

And there is the command of the Selenium IDE, maybe it could help you something:

https://www.seleniumhq.org/selenium-ide/docs/en/api/commands/#select-window

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Highlighted

Re: UI Flow WebApp with Dynamics 365

Many thanks for the command list link. 

Will have a look at that. 

The form is in D365F&O. 

Guess you don't have access to such a machine. 

Thanks for the feedback. 

Ludwig

 

Highlighted

Re: UI Flow WebApp with Dynamics 365

Hi Lin Tu, 
I can possibly show you the problem even if you don't have a D365FO system available. 

Not sure whether this is common to do a screenshare?!

Would that be possible?

I believe the problem is related to all D365 products not only FO. 

Best regards, 

Ludwig

Highlighted

Re: UI Flow WebApp with Dynamics 365

Also got that one fixed. 

The problem was the execution speed. 

Once I slowed that down, things correctly loaded and the process completed successfully. 

Many thanks, 

Ludwig

View solution in original post

Helpful resources

Announcements
secondImage

August 2020 CYST Winners!

Check out the winners of the recent 'Can You Solve These?' community challenge!

thirdImage

Experience what's new for Power Automate

Join us for an in-depth look at the new Power Automate features and capabilities at the free Microsoft Business Applications Launch Event.

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (3,298)