cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mrQ
Helper V
Helper V

UI Flow & Gateway?

Hey there

 

I just tried to give UI Flows a go. I was also able to successfully create them - they run perfectly fine when I test them. However, I wanted to include them in regular flows and when I chose the desktop or web action for UI flows, I get the following window. Doesn't look like all the videos I've seen. Also, the "gateway" dropdown is empty.

ui-flow.png

 

Does anyone else experience this?

 

Kind regards,

1 ACCEPTED SOLUTION

Accepted Solutions
v-litu-msft
Community Support
Community Support

Hi @mrQ,

 

If you want to add it into a regular flow, you need to install on-premise gateway:

This is the document on how to set up UI Flows on your device:

https://docs.microsoft.com/en-us/power-automate/ui-flows/setup

 

This is the document on how to run UI flows from other Flows:

https://docs.microsoft.com/en-us/power-automate/ui-flows/run-ui-flow

 

I hope something helps.

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

6 REPLIES 6
v-litu-msft
Community Support
Community Support

Hi @mrQ,

 

If you want to add it into a regular flow, you need to install on-premise gateway:

This is the document on how to set up UI Flows on your device:

https://docs.microsoft.com/en-us/power-automate/ui-flows/setup

 

This is the document on how to run UI flows from other Flows:

https://docs.microsoft.com/en-us/power-automate/ui-flows/run-ui-flow

 

I hope something helps.

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

I did all this and seems ok, till i run a flow. It says invalid connection credentials.

Hi, 

Did you get this resolved?

I run into the same issue. 

Best regards, 

Ludwig

It seems like @v-litu-msft  provided the right answer. You'll need to install a gateway first, before you can run it.


Please click Accept as Solution if my post answered your question. Like my answer? Consider giving it a Thumbs Up. Others seeking the same answers will be happy you did.

Hi @lreinhard7 

 

Yes, I followed the post from @v-litu-msft. You need to install a gateway first, even if it is an attended flow. 

 

Kind regards,

jaymdav
New Member

I'm trying to do this but cannot get past setting up the connection to the gateway. It will not accept my domain/username and password no matter what variation I use. What should I be using as the domain/username? I've tried what shows up in Power Automate as the domain/username for the gateway itself which matches the domain/username for my account but that gets rejected as well. What details did you all provide?

Helpful resources

Announcements
MPA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

R2 (Green) 768 x 460px.png

Microsoft Dynamics 365 & Power Platform User Professionals

DynamicsCon is a FREE, 4 half-day virtual learning experience for 11,000+ Microsoft Business Application users and professionals.

Top Solution Authors
Users online (1,261)