cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Kudo Collector
Kudo Collector

Unable to Format Link in a Table

I'm trying to retreive multiple items from a SharePoint list and send them as a table in an Email, one of the fields needs to be the link back the the list item. I have set Is HTML property of the Send an Email action to True and tried to wrap the value in an HREF tag, but it's not working. Can someone tell me what I might be doing wrong or suggest an alternative approach? 

WFwithLink.png

 

@Pieter_Veenstraany ideas?

Dean Gross

Office 365- MSCA
SharePoint - MCSE
Microsoft 365 Enterprise Administrator Expert
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Unable to Format Link in a Table

Hi Dean,

 

Have a look at chakkaradeep's post: https://www.chakkaradeep.com/2018/05/02/building-html-tables-in-your-flows/

 

He is doing exactly what you are trying to do.

View solution in original post

3 REPLIES 3
Highlighted

Re: Unable to Format Link in a Table

Hi Dean,

 

Have a look at chakkaradeep's post: https://www.chakkaradeep.com/2018/05/02/building-html-tables-in-your-flows/

 

He is doing exactly what you are trying to do.

View solution in original post

Highlighted
Kudo Collector
Kudo Collector

Re: Unable to Format Link in a Table

Thanks, that article was very helpful. 

Any idea why the Create Table Action does not parse HTML?

 

It would seem that this common scenario should be easier to implement. A typical business user should not have to hand code html .

Dean Gross

Office 365- MSCA
SharePoint - MCSE
Microsoft 365 Enterprise Administrator Expert
Highlighted
Responsive Resident
Responsive Resident

Re: Unable to Format Link in a Table

There's an older post on this forum that talks about how HTML tables encode Values (and I say the word 'Value' in context of the HTML Table's two custom columns: (1) Header and (2) Value).

It's my assumption that the developers intended the values to be a one-for-one (i.e. straight text) translation. For example, if a value was "<no value entered>", they would not want Flow to inadvertantly default to trying to translate that into HTML--the net result would be trying to translate that into an HTML tag when it really shouldn't.

So what ends up happening is that they take the text in the Value field and convert the characters that may have HTML carryover and encode those characters. For example, quote becomes "&quot;" (without the quote-symbols), greater than (">") becomes "&gt;", less than ("<") becomes "&lt;", and strangely enough... ampersand becomes ("&amp;"). As you can see, the pattern for these encoding is [ampersand][code][semicolon]. If you want to see what I'm talking about, create a variable and set the value to your HTML table--then you can see what your actual HTML table looks like.

The workaround is to Compose your HTML table and replace the encoded values with their true values. Doing this has potential for consequences (mentioned above); but if you don't anticipate receiving values in brackets or quotes, then this workaround should work fine.

You can see some great examples of this in the link I referenced above provided by @DougL .

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (5,958)