cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
rob7785
Advocate I
Advocate I

Unable to apply Template to SP site

Hi Guys,

 

I've created a flow which creates SP site based on information in a submitted form, it works upto the point of applying a template.
I get this error, 
{"odata.error":{"code":"-1, Microsoft.Data.OData.ODataException","message":{"lang":"en-US","value":"The parameter 'weburl' in the request payload is not a valid parameter for the function import 'ApplySiteDesign'."}}}

 

The site i'm using for a template is called "template" its just libraries and empty folders, I got the GUID for this site using http GET which was then used as Site design ID in Http POST along with the newly created site address which I want to apply the template to.

 

I just can't figure out why its flagging it as an error done several searches and read blogs but as far as can tell should work fine I'm stumped any advice would be appreciated?

GUID.png

 

Error.png

0 REPLIES 0

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Community Calls Conversations

Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (4,308)