cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
LostInTheSauce
Helper I
Helper I

Unable to attach SharePoint item attachments to email (file content isn't working)

Previously would be able to have a flow get an attachment from a SharePoint list.  Currently it does not work.  I've used Get Attachment then Get Attachment Content.  This would be linked to the Send an Email (outlook).  It no longer is working.  Is anyone experiencing the same issue?

By not working:  It no longer allows me to make a new flow with the same actions to add it to an email.  

9 REPLIES 9
efialttes
Super User
Super User

Hi

Can you share a screenshot from your current flow design?

Thanx!



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Sorry I was able to figure it out. I use to have under when a file is selected to get attachment content and apply that to several conditions to emails. Now you have to have the email within the get attachment content for it to work. No sure why but now it works.

So I just ran the workflow and it doesn't work. I don't know how to attach a screen shot to this thread.

Hi @LostInTheSauce 

 

If you looking to get contents from SharePoint and attach in an email please have a look at this post

 

https://mydevexperience.wordpress.com/2019/10/12/microsoft-flow-retrieve-all-files-from-sharepoint-l...

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

Hi @LostInTheSauce,

 

Has your problem been solved?
You could add screenshots by clicking the "Camera" button:

Annotation 2020-03-24 143041.png

 

Best Regards,
Community Support Team _ Lin Tu

WF not working.jpg

Hi @LostInTheSauce 

 

Thanks for the screenshot. What you are missing is appending the attachment (filename and contents) in an array. Please follow below post

 

https://flow.microsoft.com/en-us/blog/multiple-attachments-single-email/

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

Thanks.  So I am curious, why does this format work for my flows that I built last month and prior to this month?  It's only one attachment.  In the attachment in the email, it doesn't show the file content any longer.  Did something change?

Hi,

 

Not sure what changed. If its only one attachment you can move your If condition and send email inside the loop and map the filename and content directly.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

Helpful resources

Announcements
MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

PA Survey Carousel Image.png

We want to hear from you!

If you are a small business ISV/Reseller, share your thoughts with our research team.

Users online (1,329)