cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
yoggieb
Helper I
Helper I

Unable to create text analytics connection

Hi,

 

I am unable to create a connection to Microsoft's Text Analytics API using Flow or PowerApps. Both solutions gave me a "resource not found" error. I have tried the following steps;

 

  1. API endpoint: https://eastus.api.cognitive.microsoft.com/text/analytics/v2.0
  2. Tried re-generating the key and it didn't work
  3. Tried re-creating both resource group and text analytics service, it didn't work either.

Using Postman, the connection to Text Analytics API was successful. I am not sure how else to troubleshoot on Flow or PowerApps. Appreciate any guidance. Thanks.

6 REPLIES 6
yashag2255
Dual Super User II
Dual Super User II

Hi @yoggieb 

 

Can you please post a screenshot of the flow? How are you creating the connection? What role do you have to the resource that you are creating in Azure? 

@yoggieb 

 

I just created the resource in my Azure subscription (I have the owner role to the resource and the resource group) and connected to that in flow:hans.PNG

 

I am set as a "classic administrator" to the resource.

 

When I added the connection (the first time), it worked when I put in the access key and endpoint. This issue started after I tried to switch connection to a different resource in Azure. I switched the connection back to my original resource and it still did not work.

 

I am still having an issue connecting.

 

Screen Shot 2019-06-29 at 10.39.46 PM.png

yashag2255
Dual Super User II
Dual Super User II

Hi @yoggieb 

 

That is strange. This could be a caching issue. Can you please go to Data on the left nav bar in the flow -> Connections, find the connection to azure text analytics resource and delete that. Now log out of the current session of the flow and close the browser window. Start a fresh session and check if you continue to face the issue. 

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Hi @yashag2255 ,

 

I did the following;

  1. I removed any connections related to text analytics on Microsoft Flow.
  2. Logged out of Microsoft Flow
  3. Clear browser cache
  4. Logged back onto Flow
  5. Tried to add the connection and it still failed (see screenshot below)

I have also tried the following;

  1. Delete both text analytics resource and resource group
  2. Re-create both text analytics resource and resource group
  3. I am still facing the same issue

I checked the resource metrics on Azure and there was no calls recorded to the resource. I don't think the issue is around configuration on Azure. I tried a test using the API testing console in the documentation, see here;

API testing console

 

Azure did capture the call from the API testing console. However, there was no call recorded from Flow or PowerApps.

For Connection, Name, enter the name of the Text Analytics resource that you created in Azure Portal.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (1,729)