cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jay312
Helper V
Helper V

Unable to process template language expressions for action 'Condition' at line '1' random error?

Hello 🙂

 

I had a flow that worked perfectly for months, then it just randomly decided to fail :S

 

It is a shared flow but I don't believe anyone changed anything.

 

This was the error - All I had was a simple condition box that said if question 1 = No and question 2 = No do the Yes option

 

I also copied the test results for the 2 questions to check if the value to 2 questions = no

 

For some reason one of the questions is showing as "No" which is correct and the other is showing as blank?? no idea why. I am using a Power apps form with the default option being No and the 2 choices being yes or no. No idea why Flow is not picking up the No answer?

image.png

 

 

Any ideas please?

 

image.pngimage.png

7 REPLIES 7
Mira_Ghaly
Dual Super User II
Dual Super User II

@jay312 

Are you invoking this flow from sharepoint form on powerapps ? what is your trigger to try to simulate the same at my side?

 

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

Hi @Mira_Ghaly 

 

I am using a Power apps form on a sharepoint list / site.

 

So user fills in the power app form on sharepoint and flow triggers.

 

I dont know why it randomly decided to stop working and show the "No" option for 1 of 2 questions as blank / null :s

Mira_Ghaly
Dual Super User II
Dual Super User II

@jay312 

Pretty weird but you can simply add an OR condition to fix this for the No option.

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

I may try and re-create it later but I need the and option as I wanted it to only go to yes if both questions are answered with "No"

 

 

Mira_Ghaly
Dual Super User II
Dual Super User II

@jay312 

Are you setting the default on the sharepoint list column or on the Powerapps form?

 

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

Hi,

 

I have it set to "No" as default in the sharepoint list. 

Mira_Ghaly
Dual Super User II
Dual Super User II

@jay312 

I have just tried to replicate the same and it is showing as No , can you make sure that the default is set correctly on your sharepoint list column

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

Helpful resources

Announcements
MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

New Process Advisor Capabilities carousel.png

Read the blog for the latest news

Read the latest about new experiences and capabilities in the Power Automate product blog.

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

PA Survey Carousel Image.png

We want to hear from you!

If you are a small business ISV/Reseller, share your thoughts with our research team.

Users online (3,116)