cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Unable to process template language expressions in action 'Add_member_to_group'

I am trying to set up a flow that will add a user to a group from an HTTP request trigger.  I am able to post to the HTTP request, but add the output of the HTTP request to the Add member to group action I get the following error.  any ideas? 

 

Unable to process template language expressions in action 'Add_member_to_group' inputs at line '1' and column '1598': 'The template language expression 'triggerBody()?['email']' cannot be evaluated because property 'email' cannot be selected. Property selection is not supported on values of type 'String'. Please see https://aka.ms/logicexpressions for usage details.'.

 

Here is my JSON Schema for the HTTP Request:

{
    "$id": "http://example.com/example.json",
    "type": "object",
    "definitions": {},
    "$schema": "http://json-schema.org/draft-07/schema#",
    "properties": {
        "email": {
            "$id": "/properties/email",
            "type": "string",
            "title": "The Email Schema ",
            "default": "",
            "examples": [
                "<youraddressgoeshere>"
            ]
        }
    }
}

And here is the format of the message that is getting posted to the HTTP Request:

{
  "email":"email.address@somecompany.com"
}

(obviously that is not a real email address)

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Frequent Visitor

Re: Unable to process template language expressions in action 'Add_member_to_group'

Identified the issue.  It was not with Flow but with the format of the message that was being sent to Flow.  Once I fixed the typo it worked like a champ!

View solution in original post

2 REPLIES 2
Highlighted
Frequent Visitor

Re: Unable to process template language expressions in action 'Add_member_to_group'

Identified the issue.  It was not with Flow but with the format of the message that was being sent to Flow.  Once I fixed the typo it worked like a champ!

View solution in original post

Highlighted
Regular Visitor

Re: Unable to process template language expressions in action 'Add_member_to_group'

Soory, could you please elaborate on the typo/ the wrong format? I'm having the same issue and i'm unable to identify where the error is.

Helpful resources

Announcements
FirstImage

Microsoft Ignite 2020

Check out the announcement of Power Platform content at Microsoft Ignite!

thirdImage

Experience what's new for Power Automate

Join us for an in-depth look at the new Power Automate features and capabilities at the free Microsoft Business Applications Launch Event.

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (5,640)