cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
random_intern
Regular Visitor

Unable to save flow with error

I am unable to save the flow with the following error

random_intern_0-1597136547464.png

This error only happens when I add the 'Send an Email' action to the flow. But for the other cases in 'if yes', I have implemented the same thing as the shown in the screenshot above and it still works, only this block does not work and stops me from saving. Any help would be appreciated, thank you.

1 ACCEPTED SOLUTION

Accepted Solutions
Mira_Ghaly
Dual Super User II
Dual Super User II

@random_intern 

When you are setting the values on your email step make sure you are selecting the values from the Trigger Action not from the Update Item Step.

 

If this post helps you with your problem, please mark your as Accepted solution.

If you like my response, please give it a Thumbs Up.

MG (Naturally Curious)

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

View solution in original post

4 REPLIES 4
Mira_Ghaly
Dual Super User II
Dual Super User II

@random_intern 

When you are setting the values on your email step make sure you are selecting the values from the Trigger Action not from the Update Item Step.

 

If this post helps you with your problem, please mark your as Accepted solution.

If you like my response, please give it a Thumbs Up.

MG (Naturally Curious)

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

View solution in original post

I'm sorry but do you mind elaborating a bit more as I am still a beginner in using Power Automate.

I have done the same thing in other cases but this is the only cases where the error pops up

random_intern_0-1597137219858.png

Thank you for your reply!

@random_intern 

Can you move the Update Item 4 after the Email Step.

 

I mean when you select the variables from Dynamic Content make sure you are using the Variables from the Trigger Action in your flow.

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Thank you for your reply!

Thank you very much for your help, I just checked again and I realized that I accidentally put dynamic variables from the update item  step instead of the trigger action. Thanks again for your help 🙂

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MSFTBizAppsLaunchEvent

Experience what’s next for Power Virtual Agents

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Users online (70,130)