cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Microsoft
Microsoft

Underscore at the beginning of internal SPO column name / "search" filter query?

I'm trying to use a filtered "Get Items" step to pull up a list of SPO list queries in a certain category, but I've discovered that the internal name for the column begins with an underscore (%5F). I've tried having my entry for the "Filter query" field be:
_Category eq 'category name'
or
%5FCategory eq 'category name'
but both of those cause the step to fail. How do I phrase my query so that it works, or, failing that...is there a "filter query"-friendly query that filters by rows containing a phrase?

Thank you!

2 REPLIES 2
Community Support
Community Support

Hi @beck_,

 

Could you please share more details about the "%5FCategory" column in a sharepoint list?

What is the type of "%5FCategory" column?

 

I have made a test on my side and have created a "%5FCategory" column in a sharepoint list with Single line of text type.

 

You could refer to screenshot below to create the flow:

Capture.PNG

 

The expression in the Filter Array field as below:

OData__x0025_5FCategory eq 'a'

 

The flow would run successfully as below:

Capture.PNG

 

Best regards,

Alice

 

 

Hello Alice,

 

The column type is also a single line of text. However, when I ran the query that you provided (with a replaced with the desired value), the Flow returned a 400 error, with the following detail:

Column 'OData__x0025_5FCategory' does not exist. It may have been deleted by another user.

 

Trying the query without OData  or OData_ returns the same error.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Top Solution Authors
Top Kudoed Authors
Users online (14,183)