cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Unexpected token u in JSON at position 0 using forEach in web UI Flow

Hi all!

Since yesterday, my web UI Flows started to give me the error; "Unexpected token u in JSON at position 0" when using an input variable as the array in a forEach loop.

I'm in Europe (https://emea.flow.microsoft.com/).

Anyone else seeing this?

 

Steps to reproduce:

open | https://www.bing.com

forEach | values | value

echo | ${value}

end

When saving the above Selenium IDE code, I get the error.

 

Best regards,

Hans E

7 REPLIES 7
v-litu-msft
Community Support
Community Support

Hi @Anonymous,

 

Could you please share an instance of array, is there any format error?

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Anonymous
Not applicable

Hi!

It doesn't matter what the array look like, because it's an input variable:

https://docs.microsoft.com/en-us/power-automate/ui-flows/inputs-outputs-web

The error comes when trying to save, not at runtime.

If I define an array in the code, it works just fine, but the problem seems to be when it's an input variable.

 

Best regards,

Hans E

@Anonymous remove the echo value in foreach to solve!

Anonymous
Not applicable

Hi @pippo1!

Thanks for your input!

I forgot that echo is not supported in Power Automate!

However, even if I replace 'echo' with i.e. 'click', the error is sadly still the same. 

//Hans E

Did you manage to resolve this issue? I am unfortunately facing the same problem, but I can't seem to find a solution anywhere.

@Anonymous 

After quite some time testing I figured out a solution, or at least a workaround, for this issue. Posting here in case others are still experiencing the same problem.

It appears that Power Automate requires that the Target and Value inside the for each Selenium activity is identical. The below image shows a configuration that works:

Svenny_0-1594423317987.png

If you try to set the value field to something else, e.g. the typical "itr" or "iterator", you will not be able to save the flow and the error occurs. See example of the configuration which will cause the error below:

Svenny_1-1594423527451.png

According to Selenium tutorials I have seen this configuration should be valid. Seems to be a bug.

 

jhowell-sfccc
Regular Visitor

I hope this bug gets fixed soon. Trying to work around it is becoming incredibly annoying.

 

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Users online (4,680)