cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Zhangzhonghao
Helper II
Helper II

Unknown error when using HTTP action to call graph API (Create a Team)

I was using HTTP action to call graph API to create a team of Microsoft Teams, an error occurred after the flow finished. I have registered an Azure AD App and grant the Group.ReadWrite.All permission. See the details from the below pictures:

Flow to call the api:Capture.PNG

Error:

Capture1.PNG

 

Anyone can help? Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @Zhangzhonghao ,

 

Just tested this on my end and got the same error as you.
I managed to workaround it changing the endpoint to use the 'beta' version instead of '1.0'.

 

image.png

 

Could you test it and verify if you still have the same issue when using this endpoint?

Regards,

Ricardo

View solution in original post

4 REPLIES 4
Zhangzhonghao
Helper II
Helper II

Update for this post. The error may caused by the incorrect permissions of my registered Azure AD App, so I followed the guide https://www.lee-ford.co.uk/using-flow-with-graph-api/ to registered an new Azure AD App and set the permission as required.Capture.PNG

 

Update the body with owners@odata.bind property as the guide mentioned. Capture1.PNG

Finally I got a BadRequest error:

{
  "error": {
    "code""BadRequest",
    "message""Invalid bind property name owners in request.",
    "innerError": {
      "date""2020-08-26T10:21:29",
      "request-id""82479320-f8ff-425f-8c58-7c097e506399"
    }
  }
}
 
Anyone can help me with this issue? Very appreciate!

Hi @Zhangzhonghao ,

 

Just tested this on my end and got the same error as you.
I managed to workaround it changing the endpoint to use the 'beta' version instead of '1.0'.

 

image.png

 

Could you test it and verify if you still have the same issue when using this endpoint?

Regards,

Ricardo

View solution in original post

@rimatos Thanks for your help!!! Yeah, I just replaced to "beta", it worked for me. Hope you can add this information to that API Doc, I spent two days stucking in this issue...😫

Hi @rimatos , I've got a new problem with calling graph api to create a plan(Planner). Here is the details: https://powerusers.microsoft.com/t5/Building-Flows/Flow-failed-when-calling-createPlan-graph-API/m-p..., could you please help to take a look? Very appreciate!

Helpful resources

Announcements
MPA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (1,560)