cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
faxmaskin
Frequent Visitor

Unwanted Read Only column in SharePoint - how do I get rid of it?

Hi!

 

Usually just searching this awesome forum saves my day and solves all my problems, but this time I'm close to a deadline and I can't tell if it's my patience or my searching that is lacking. Anyhow, I building a flow that's copies, creates and converts files around different SharePoint lists and libraries (without any trouble). The problem arises in an otherwise unproblematic action, namely the "Update file properties" action for a multi-select column in SharePoint Document Library (which never troubled me before).

 

The error message reads as follows: 

"The 'inputs.parameters' of workflow operation 'Uppdatera_metadata_för_originalfil' of type 'OpenApiConnection' is not valid. Error details: The API operation does not allow writing a value for parameter 'item/M_x00e5_lgrupp[0]/Id'. This parameter is read only."

 

I hope someone quickly can spot what I can't see and that the Swedish in the picture doesn't confuse all to much. 😊

 

Thanks a million! 

/Joakim
error1.pngUpdate file properties.png

 

1 ACCEPTED SOLUTION

Accepted Solutions

Turns out I was to blame, the Read Only was caused by a parallel process that was trying to write to the same field... When I rearranged the flow to run sequentially it worked like a charm. 😎

View solution in original post

5 REPLIES 5
ChristianAbata
Community Champion
Community Champion

hi @faxmaskin  It looks like a limitation This parameter is read only so you can't change the parameter my friend.



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

@ChristianAbata, Any insight to why that is? Hasn't encountered it before with similar flows. I tested to recreate a column with multi-select but the problem was the same. 

When I rearrange my flow so that the "Update file properties" action is inside a "For Each" loop the flow is successful, but only the last value from my multi-select column is transferred to the other library/list. 

faxmaskin
Frequent Visitor

I found proof of that this used to work fine in this post: 
https://powerusers.microsoft.com/t5/Building-Flows/Update-a-List-Item-Multiple-Select-Choice-Field/t...

 

@v-yuazh-msft showed the solution that I've been using, with using the entire array. But for some unknown reason it now states that my SharePoint column is ReadOnly, which (again) isn't something I've set up or want. 

Turns out I was to blame, the Read Only was caused by a parallel process that was trying to write to the same field... When I rearranged the flow to run sequentially it worked like a charm. 😎

gdc1
Regular Visitor

how did you fix this? I'm having the same problem. Thanks!

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

MPA Licensing.jpg

Ask your licensing questions at the Power Automate AMA!

Join Priya Kodukula and the licensing team, super users and MVPs to find answers to your questions on Power Automate licensing.

Users online (1,487)