cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Jezter12
Resolver I
Resolver I

Update a dynamic document library column, List does not exist at site with URL error

Good afternoon,

 

This problem is causing me a few headaches.

 

I have created an app that will allow me to upload documents to a selected (In App) document library. This works.

However i now want to update a column in that document library to provide some meta data against it.

Everything is captured app wise and yet where i fall down is the final step, which is the Send HTTP request to sharepoint part of my flow.

See below

Jezter12_0-1655900180984.png

The libraries are stored on the same collection so the Site Address is fine

Its the dynamic library name where I am getting issues. As far as I can tell I am using the display title of the library in the get by title element. But I persistently get a 404 error and the library not found.

 

If I were to type in a library name directly to that section I still get the same issue.

As below..

Jezter12_1-1655901694324.pngJezter12_2-1655901755513.png

Jezter12_3-1655901809198.png

 

Jezter12_4-1655901897487.png

Just what the heck am I doing wrong? Any help would be appreciated.

 

 

 

 

 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Jezter12
Resolver I
Resolver I

Dammit of all the daft things.

 

The issue is/was it looks like a space was input at the end of the document library name, on creation.

View solution in original post

3 REPLIES 3
Pstork1
Dual Super User
Dual Super User

Go to the Document library and take a look at the address in the url. For document libraries with spaces in the name the spaces are converted to '%20' to encode the space.  So I think the actual name of the library you need for the url is 'Force%20Access%20System' not 'Force Access System'



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
Jezter12
Resolver I
Resolver I

Dammit of all the daft things.

 

The issue is/was it looks like a space was input at the end of the document library name, on creation.

Yep i had already tried that, which is what the variable in my flow was for. But I have now solved it. Thank you for your prompt reply 🙂

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Users online (5,276)