cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Migloo
New Member

Update file properties - do not see my custom columns

Hello,

 

I have a Microsoft Form survey asking few questions and to upload a file. 

I have a flow working well to create the uploaded file in SharePoint page.

Then I want to update the column "Country" of the created file with one value of one of the question

Migloo_0-1618870000718.png

On the picture you can see three PDF files created thanks to the flow.

I am blocked to add a value in the column "Country"

 

Migloo_1-1618870187160.png

In the square red/pink, I am expecting the see the list of column of my page .

Whereas in the Sharepoint file, when I see Details, I have the list of properties including Name, Title, County

Migloo_2-1618870284667.png

 

Thanks for helping me

3 REPLIES 3
henkenTech
Resolver II
Resolver II

Hey there,

 

right now, location columns can only be updated by putting a JSON object using the HTTP connector for Sharepoint. This is not that straightforward, so, If it’s only a country value you need, add a choice column instead and load a list of countries from Wikipedia, etc. 

if you want to read yo yo how to use the http connector anyway, see here: https://powerusers.microsoft.com/t5/Power-Apps-Community-Blog/How-to-update-a-SharePoint-location-fi...

 

Max

Migloo
New Member

Hi Max, 

Thanks for the advice, effectively I changed to a choice question with drop down list of all country. It is well set up.

But it doesn't change the fact I don't see the column "Country" of my SharePoint page in the "Update file properties" ?

Is there something I missed ?

henkenTech
Resolver II
Resolver II

Hey there,

 

could be a couple of reasons:

  1. Did you create a new choice column or did you change the type of the existing column? Might not show up if you just changed the type;
  2. Did you add the column to a specific view and/or you are limiting the action to columns of a particular view the column is not included in? In your screenshot, this doesn't seem to be the case, but just double check.
  3. Did you tick the box to "add column to all content types" when you created it?
  4. When you change columns on SP, you need to refresh PowerAutomate in your browser for the changes to show up (probably obvious).

Can't really think of anything else right now apart from delete the action and add it again. Also what sometimes does help is to switch on experimental features in Flow, as the actions are displayed a little different. You can do that in the settings with your flow open:

 

Screenshot 2021-04-20 091159.png

 

Click on "View all Power Automate settings" and then enable the option at the bottom.  

 

Max

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (3,667)