cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ScottRMeredith
Helper I
Helper I

Update second SharePoint List from first list flow connected by a people picker field

I have two SharePoint lists, one is a tracker and the other is the actual audits.  I want to use flow to update the tracker when an audit is submitted.  I have a get items action followed by an update list item action.  I am trying to connect the two by comparing the employee's people picker/person field that is in each SharePoint list.  I have found a thread that talked about using the filter array instead of the filter by option in the get items action, https://powerusers.microsoft.com/t5/Using-Flows/Updating-sharepoint-list-from-MS-Form/m-p/436258#M10..., but I get an error.

 
 
 
 

Error.PNG

 

Here is how my flow is currently built.

 

ScottRMeredith_0-1596845927940.png

 

 
 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @ScottRMeredith,

I am able to replicate the issue below. I think you have selected 'Item (Table item entity)' as an input to the 'Apply to each' from the 'Dynamic Content' popup, which automatically created the second 'Apply to each'. Please follow the below steps.

1. Remove the second 'Apply to each' action in the screenshot below.

sudharsan1985_0-1596860314024.png

2. Make sure you use the 'Update Item' action inside the first 'Apply to each' like shown below with the value for Id as 

items('Apply_to_each')?['ID']

sudharsan1985_1-1596860400362.png

Please change the flow as mentioned and it should work fine.

 

Hope it helps, please like it or mark it as a solution if it resolves your clarification or issue
-Sudharsan K...

Hope it helps, please like it or mark it as a solution if it resolves your clarification or issue
-Sudharsan K...

View solution in original post

3 REPLIES 3
ScottRMeredith
Helper I
Helper I

I don't know why but second image won't display in the original post.  Flow.PNG

Hi @ScottRMeredith,

I am able to replicate the issue below. I think you have selected 'Item (Table item entity)' as an input to the 'Apply to each' from the 'Dynamic Content' popup, which automatically created the second 'Apply to each'. Please follow the below steps.

1. Remove the second 'Apply to each' action in the screenshot below.

sudharsan1985_0-1596860314024.png

2. Make sure you use the 'Update Item' action inside the first 'Apply to each' like shown below with the value for Id as 

items('Apply_to_each')?['ID']

sudharsan1985_1-1596860400362.png

Please change the flow as mentioned and it should work fine.

 

Hope it helps, please like it or mark it as a solution if it resolves your clarification or issue
-Sudharsan K...

Hope it helps, please like it or mark it as a solution if it resolves your clarification or issue
-Sudharsan K...

View solution in original post

That worked thank you.  Now I get to create six times because my process has a one to many relationship.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Users online (2,815)