cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Updating Managed Metadata Column value.

 

I have a flow configured to get data from SharePoint list item and update a word document.

All the column values are getting updated as expected however I have Managed Metadata Column for Location. And the Value for this is not getting updated.

So I tried to create a new column with Single line of text and used Updated File Properties to get the values from Metadata Column.

And I was able to get the expected output. But along with the value, I also see the GUID 

I came across this page. And tried the suggestion provided 
https://powerusers.microsoft.com/t5/General-Flow-Discussion/Condition-is-failing-for-managed-metadat...         

And ended up getting this error

The execution of template action 'Apply_to_each' failed: the result of the evaluation of 'foreach' expression '@triggerBody()?['entity']?['value']' is of type 'Null'. The result must be a valid array.

 

Any suggestions. 

 

Below is the screenshot of my flowWorking flow gets GUID of Metadata columnWorking flow gets GUID of Metadata columnResult with the GUIDResult with the GUIDMade changes to the flowMade changes to the flowflow failed with errorflow failed with error

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support
Community Support

Re: Updating Managed Metadata Column value.

Hi @jean9681blr,

 

It seems that you are using action Get item but not Get items, so there is no need to add Apply to each action in your flow.

I have made the following test which is working properly.

1.PNG2.PNG3.PNG

Please try again with it on your side. 

 

Best regards,

Mabel

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
Highlighted
Community Support
Community Support

Re: Updating Managed Metadata Column value.

Hi @jean9681blr,

 

It seems that you are using action Get item but not Get items, so there is no need to add Apply to each action in your flow.

I have made the following test which is working properly.

1.PNG2.PNG3.PNG

Please try again with it on your side. 

 

Best regards,

Mabel

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted
Frequent Visitor

Re: Updating Managed Metadata Column value.

Thank you 
It worked as expected. 🙂

 

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (7,724)