cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Memorable Member
Memorable Member

Usage of the ETag

Hey all,

 

 

In my Flow at one point I want to send a link that opens a generated word document in Microsoft Teams in View mode.

I found a way to open it but everytime the document opens I get an error.

 

 

So I need a link like this, with the ETag in Bold:

https://teams.microsoft.com/_#/docx/viewer/teams/https:~2F~2F<tenant>.sharepoint.com~2Fsites~2F<TeamName>~2FDocuments~2F<FolderName>~2F<FileName>.docx?threadId=19:<Channelid>@thread.skype&baseUrl=https:~2F~2F<tenant>.sharepoint.com~2Fsites~2F<SiteName>&fileId=285CAB80-E9E9-441E-822C-3A486EDFA7F4&ctx=files&viewerAction=view

So I retrieve the ETag from the previous step that contains the creation of a document.

But when my flow runs the ETag is returned this way in the link:

"{A6994BF5-8008-46C0-8BA4-970435CD2AD3},1"

So now my question is how can I get rid of the quotes and brackets so I only have the ETag numbers.

If this can be solved my Flow would be finished finally.

 

Thanks in advance

 

Kind regards

 

 

Tom



If this reply has answered your question or solved your issue, please mark this question as answered.

Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up.

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (4,526)