cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
New Member

Use Microsoft Flow to send Power BI Subscription email to another recipient

I am trying to create a flow that 'When a new email arrives' to my inbox from a Power BI subscription to send an email to another recipient with the attachment only. The Flow works, but it is sending 2 emails instead of 1 email. How do I get the Flow to only send 1 email with the attachment?

1 ACCEPTED SOLUTION

Accepted Solutions

The reason the Apply to each is being created is because you can have more than one attachment, this may be an error in the UI though. I had the same issue when I tried to reproduce your Flow, but I was able to accomplish what you are seeking by using the Forward emails with and without attachment from Office 365 template and just deleting the 3rd and 4th action and saving:ForwardEmailAttachments.PNG

NOTE: I was able to change the Has attachment to Yes without triggering the Apply to each

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

4 REPLIES 4
Super User II
Super User II

If you could provide an expanded screenshot of your Flow and steps, and of any detailed error messages you're receiving we could likely better assist you.

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

The Flow is working, but it is sending the email to the recipient twice instead of once (duplicate email). It may have to do with the ''Apply to each", which keeps showing up as required when I create the "Send an email" action.

 

Microsoft Flow.png

The reason the Apply to each is being created is because you can have more than one attachment, this may be an error in the UI though. I had the same issue when I tried to reproduce your Flow, but I was able to accomplish what you are seeking by using the Forward emails with and without attachment from Office 365 template and just deleting the 3rd and 4th action and saving:ForwardEmailAttachments.PNG

NOTE: I was able to change the Has attachment to Yes without triggering the Apply to each

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

Thanks so much! Worked like a charm!

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Solution Authors
Top Kudoed Authors
Users online (7,609)