cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
isdavid
New Member

Using a bad HTTP request in a flow

Im trying to build a flow that will take into account getting back a 400 from an HTTP request. If I get a 200 I want x to happen and if I get back anything else I want it to do x. Issue is that when the server returns a 400, the flow fails at the HTTP step because "Action 'HTTP' failed - Bad request" and it doesnt continue to the condition step. 

 

Thanks a lot

1 ACCEPTED SOLUTION

Accepted Solutions
shoog
Super User
Super User

Make sure the "Run after" setting for the condition step includes the failed option, that seems to be missing judging from your description.

View solution in original post

2 REPLIES 2
shoog
Super User
Super User

Make sure the "Run after" setting for the condition step includes the failed option, that seems to be missing judging from your description.

isdavid
New Member

Thanks a lot, that was it. Had no idea 'run after' was there. Appreciate it. 

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

365 EduCon 768x460.png

Microsoft 365 EduCon

Join us for two optional days of workshops and a 3-day conference, you can choose from over 130 sessions in multiple tracks and 25 workshops.

Users online (3,355)