cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
stevenls
Helper IV
Helper IV

Using a variable as a mention

Hey there,

At the end of a flow I have a variable of a persons name that I want to use as a mention.

 

I have a step to post a message to a Teams channel and in the body I use @variablename.  What I am getting though is

 

<p>@{variables('Technician')}</p>

 

Written to the channel.  What am I missing in relation to actually showing the value of the variable.

 

Thanks

 

2 ACCEPTED SOLUTIONS

Accepted Solutions
yashag2255
Dual Super User II
Dual Super User II

Hi @stevenls 

 

You can check this post here: https://powerusers.microsoft.com/t5/Building-Flows/Can-you-Mention-anyone-in-Teams-from-a-flow/td-p/...

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

v-alzhan-msft
Community Support
Community Support

Hi @stevenls ,

 

You should take a try as below:

<at>Test1@XXXXXX.com</at>

1.png

The message would be sent as below:

2.png

 

Best regards,

Alice   

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
yashag2255
Dual Super User II
Dual Super User II

Hi @stevenls 

 

You can check this post here: https://powerusers.microsoft.com/t5/Building-Flows/Can-you-Mention-anyone-in-Teams-from-a-flow/td-p/...

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

v-alzhan-msft
Community Support
Community Support

Hi @stevenls ,

 

You should take a try as below:

<at>Test1@XXXXXX.com</at>

1.png

The message would be sent as below:

2.png

 

Best regards,

Alice   

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

In my dumbness I wasn't using the fully qualified email address as the mention from the variable - once I changed that works a treat!

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Power Automate Designer Feedback_carousel.jpg

Help make Flow Design easier

Are you new to designing flows? What is your biggest struggle with Power Automate Designer? Help us make it more user friendly!

Top Solution Authors
Users online (1,928)