cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
scottgm
Level: Powered On

Using executeFlow in SharePoint column

Hello, 

 

I have flow set up using the trigger "for a selected item".  To trigger this flow I have added a button in one of my SharePoint columns using JSON formatting. This has worked perfectly for months and has recently stopped functioning all of a sudden. 

 

Does anyone know if there has been a change to the CustomRowAction of ExecuteFlow that might have broken this?

 

For the purposes of this example, I have replaced my Flow GUID below with 00000s. 

 

{
"elmType": "button",
"style": {
"border": "none",
"background-color": "transparent",
"color": "#0078d7",
"cursor": "pointer"
},
"txtContent": "Email Coordinator",
"customRowAction": {
"action": "executeFlow",
"actionParams": "{\"id\": \"000000-000000-000000-000000\"}"
}

3 REPLIES 3
Super User
Super User

Re: Using executeFlow in SharePoint column

I'm assuming you got the idea for this from SharePoint Siren - Manually Executing a Flow from SharePoint with Column Formatting? As far as I know, there haven't been any updates to this functionality that would make it stop working. @aprildunnam (also @aprildunnam on Twitter) wrote that article, so maybe she can provide some insight. 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

 

Community Support Team
Community Support Team

Re: Using executeFlow in SharePoint column

Hi @scottgm,

 

I am tested on my side that executes the button in SharePoint I created before, it works well and not appear any issue.

 

What's the error report when you perform it?

Have you changed the Flow staus? Turn off or delete it?

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

scottgm
Level: Powered On

Re: Using executeFlow in SharePoint column

@v-litu-msft , Thanks for getting back to me. 

 

The button appears at as a Hyperlink in the SP column but does not take any action when clicking it. Before when it was clicked the pop-up window on the right hand side would appear to execute the flow that it was calling.

 

I will try re-creating the flow and update the ID to see if this helps.

 

Thanks.

Helpful resources

Announcements
firstImage

Better Together Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

firstImage

Incoming: New and improved badges!

Look out for new contribution recognition badges coming SOON!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Community Summit North America

The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Top Kudoed Authors
Users online (7,372)