cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Scooter
Regular Visitor

Using the Expand Query in CDS List Records - Bug?

How's anyone been able to successfully use the Expand Query field on the List Records (CDS) where you need to connect from 2 levels below.

 

As an example - I'm wanting to connect from a child record to it's account, and then from that account connect to it's primary contact and pull back some attributes from that primary contact. I've been able to connect to the Account and pull the attributes, but as soon as you use the $expand= - this never ever works.

 

I've used XrmToolBox – FetchXML Builder – Power Automate Parameters – Expand Query (to even produce the parameters and I've pasted those into here and it doesn't work). I've double checked all syntax via Microsoft Documentation and it's definately looking like a bug.

 

Any assistance or help would be greatly appreciated.

1 REPLY 1
ManishJain
Solution Sage
Solution Sage

Hi @Scooter ,

 

Can you please share your odata query which you are getting. 

 

It should be like regardingobjectid_account($expand=primarycontactid($select=firstname)) in the expand part.

 

Thanks

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Users online (25,863)