cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Lewkir
Resolver I
Resolver I

Wait For Approval Failing due to approvalName Null

I have an approval proccess which starts with a create approval:

 

Approval Start.png

 

and later in my flow I have a wait for approval:

 

Approval wait.png

 

 

 

When I run my flow, however, I get the error:

 

Approval fail.png

 

I understand that there is some value it is looking for called approvalName but I have no idea where that comes from.

 

It isn't a field in the Create Approval controll so I am a bit confused as to what is missing.

1 ACCEPTED SOLUTION

Accepted Solutions

Hey turns out I am the fool. failed to put the "Create approval" in the right leg of a conditional earlier in the flow so there was nothing for it to find.

 

Thanks anyway

View solution in original post

3 REPLIES 3
PrasadAthalye
Super User
Super User

@Lewkir - Is the value given in the assigned to within create Approval correct? In the flow run, what do you see in assign to field?

Please Like and Mark this as Answer if it resolves your Issue.

Power Automate Community

Hey turns out I am the fool. failed to put the "Create approval" in the right leg of a conditional earlier in the flow so there was nothing for it to find.

 

Thanks anyway

View solution in original post

Glad you figured out

Please Like and Mark this as Answer if it resolves your Issue.

Power Automate Community

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Users online (2,933)