cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Dave-Hicks
New Member

When a file is created (properties) Not Triggerring

Hi Everyone,

 

I am relatively new to Flows and I have created a flow as per below, but it does not always trigger. The theory is that a file is dropped in to a specific folder and then the file is emailed then copied in to a "Sent" folder and the original is deleted. It worked fine at first and now generally does not trigger.

 

The files that are droped in to this folder are either saved directly in to the folder or they are cut and pasted from another Sharepoint folder

 

Can anyone help me please? 🙏

 

Screenshot 2020-07-28 at 09.48.59.png

 

 

 

9 REPLIES 9
Mira_Ghaly
Dual Super User II
Dual Super User II

@Dave-Hicks 

Can you please try using this Trigger instead?

Mira_Ghaly_0-1595933334901.png

 

If this solves your problem, please mark as accepted solution

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

Thanks for your time on this... @Mira_Ghaly

I have tried what you have asked but the dynamic content is different.

This is now how it looks but it fails on the Send Email stating there is a "Null" field.

 

Screenshot 2020-07-28 at 12.22.03.png

Thanks,

 

Dave.

@Dave-Hicks 

Can you please paste a screenshot of the failed run?

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

@Mira_Ghaly 

 

See screenshot..Thanks!

 

Screenshot 2020-07-28 at 13.53.58.png

 

Hi @Dave-Hicks ,

 

Please make sure that the Dynamic content you fill in the Attachment Content field comes from the Get file content action.

Then check whether the body of the Get file content action in Flow run history is empty.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

I have got it working up to the last action now (Delete File) See below:

 

Screenshot 2020-07-29 at 14.52.37.png

 

Delete file errors with this:

 

Screenshot 2020-07-29 at 14.56.45.png

 

Thanks,

 

Dave.

 

Hi @Dave-Hicks ,

 

It seems that you need to fill the file identifier output by the trigger in the Delete file action, please try again.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

@v-bacao-msft 

 

I'm not sure what you mean...

 

Thanks,

 

Dave.

 

 

What you fill in the File identifier field of the Delete file action is File content. Have you noticed this?

 

What needs to be filled here is the File identifier.

 

 

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
MPA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

R2 (Green) 768 x 460px.png

Microsoft Dynamics 365 & Power Platform User Professionals

DynamicsCon is a FREE, 4 half-day virtual learning experience for 11,000+ Microsoft Business Application users and professionals.

Top Solution Authors
Users online (1,127)