cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

When a new email arrives to a shared mailbox it doesnt find any folders

I'm trying to use the trigger for "When an new email arrives in a shared mailbox (V2)" but when I type in the mailbox address the folders dropdown says no items. I have full access to the shared mailbox and also have tried to delete the semi colon and the trigger itself to reestablish the connection. The flow was working yesterday but stopped this morning when trying to debug another issue with our COE team.flow error.JPG

1 ACCEPTED SOLUTION

Accepted Solutions

That is just the default outlook name for the email address. I've tried typing it out fully and it does not find it either. After using the "Primary Owner" of the shared email's credentials I was able to replicate the flow and get the trigger to work correctly. It must be part of the security built into the shared folder.

View solution in original post

2 REPLIES 2
Super User II
Super User II

Hi,

I can confirm that i cannot replicate it, but my trigger does look different to yours, it shows the full email address in the Mailbox Address box, what happens if you do this?

 

Annotation 2020-01-09 082416.png

That is just the default outlook name for the email address. I've tried typing it out fully and it does not find it either. After using the "Primary Owner" of the shared email's credentials I was able to replicate the flow and get the trigger to work correctly. It must be part of the security built into the shared folder.

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Solution Authors
Top Kudoed Authors
Users online (8,819)