cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

When an item is deleted: Error 400

Hello! 

 

I am building a flow that triggers when an item is deleted on a sharepoint list, the same item is deleted from an excel document. 

The flow ran fine for a few weeks, but now i'm getting an error 400 on "When an item is deleted" step that says: 

{
"status": 400,
"message": "The changeToken refers to a time before the start of the current change log.\r\nclientRequestId: 4518454a-9776-4f69-9434-1397632fd5de\r\nserviceRequestId: 1b79c49e-0085-8000-de00-6f0960731ae3"
}
 
Not sure what has changed or how to troubleshoot this error? 
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Power Automate
Power Automate

Re: When an item is deleted: Error 400

We are checking on this and we believe this is an issue with the list changelog. If that is the case, any fix we do will not fix the flow as the flow is already set. That said, here is the workaround that you can do to recover from this issue:

  1. Edit the Flow and temporarily change the trigger to use a different Site or a different List
  2. SAVE the Flow (this is important!)
  3. Edit the Flow and change the trigger back to what it was
  4. Save and run

Let us know if the workaround fixes your flow. 

View solution in original post

8 REPLIES 8
Highlighted
Power Automate
Power Automate

Re: When an item is deleted: Error 400

Did you manually delete any items from the SharePoint list?

The error message seems to suggests that your flow is out of sync

Highlighted
New Member

Re: When an item is deleted: Error 400

Yes, to test the flow. 

How can I re-sync? 

Highlighted
Power Automate
Power Automate

Re: When an item is deleted: Error 400


@kbest wrote:

Hello! 

 

I am building a flow that triggers when an item is deleted on a sharepoint list, the same item is deleted from an excel document. 


Can you explain what you mean by "the same item is deleted from an excel document" ?

Highlighted
New Member

Re: When an item is deleted: Error 400

When an item is deleted from my Sharepoint list, I get the "Name" of that item which corresponds to a column in my excel document. I then get that row, move it to a new sheet, and delete it from the original sheet. 

Highlighted
Power Automate
Power Automate

Re: When an item is deleted: Error 400


@kbest wrote:

When an item is deleted from my Sharepoint list, I get the "Name" of that item which corresponds to a column in my excel document. I then get that row, move it to a new sheet, and delete it from the original sheet. 


Thanks. So, this scenario would require you to:

1. Build a flow with the 'when an item is deleted' in SharePoint list

2. As the output of the trigger, you get some metadata, like the Name of the item deleted

3. Using that Name dynamic property, you can then query Excel using the Excel connector to get the row

4. Once you have that row, you can either move that row to a different excel file or delete that row from that excel file

 

sp-deleted-item-excel.png

 

 

If you are looking for the flow to run if you delete that the row from the Excel spreadsheet, you will need to check if that trigger is available in the Excel connector. 

Highlighted
New Member

Re: When an item is deleted: Error 400

Thanks, I already have the flow built. My issue is the error 400 on the trigger.... 

Highlighted
Power Automate
Power Automate

Re: When an item is deleted: Error 400

We are checking on this and we believe this is an issue with the list changelog. If that is the case, any fix we do will not fix the flow as the flow is already set. That said, here is the workaround that you can do to recover from this issue:

  1. Edit the Flow and temporarily change the trigger to use a different Site or a different List
  2. SAVE the Flow (this is important!)
  3. Edit the Flow and change the trigger back to what it was
  4. Save and run

Let us know if the workaround fixes your flow. 

View solution in original post

Highlighted
New Member

Re: When an item is deleted: Error 400

I had tried moving to a new list and moving back but was not saving in between. Looks like this has fixed my issue. 

 

Thanks! 

Helpful resources

Announcements
FirstImage

Microsoft Ignite 2020

Check out the announcement of Power Platform content at Microsoft Ignite!

thirdImage

Experience what's new for Power Automate

Join us for an in-depth look at the new Power Automate features and capabilities at the free Microsoft Business Applications Launch Event.

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (9,142)