cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
JamesB-NBCC
Level: Powered On

Why aren't all my list columns being copied to second list?

I've read other posts on copying list items from one list to another, but I still haven't discovered why all of my columns arent being copied over to the second list.

List #1 has these columns names and types:

  • Attachments 
  • Title (linked to item with edit menu) 
  • Body (multiple lines of text)
  • Expires (Date)
  • IconURL (Single line of text)

List #2 has these columns names and types:

  • Attachments 
  • Title (linked to item with edit menu) 
  • Body (multiple lines of text)
  • Expires (Date)
  • IconURL (Picture) 

When an item is created in List #1, IconURL is populated with default text for that list which is a URL path to an icon.

When it gets copied to List #2, IconURL should be showing the icon instead of the path because it is formated as a picture.

 

When I create the FLOW from the source list (List #1), it looks like this:

clip.png

I know List #1 is displaying a funky name, but that's another issue, at least I know it is connecting.

 

1.   Why aren't all my columns being listed?

I created a new item in List #1 and it copied it to List #2 as it was suposed to, but it only copied the fields I linked in the "Update Item" form.

2.   Am I using the correct form to do the copying?

3.   Can a 'single line of text' field (with a URL for content) be copied to a 'hyperlink or photo' field?

 

Any help on this is appreciated!!

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Super User
Super User

Re: Why aren't all my list columns being copied to second list?

@JamesB-NBCC :

 

As far as I know, you cannot update a hyperlink or picture column using "out of the box" Flow actions.  You can get there by using the Send an HTTP request to SharePoint action.

Details and instructions can be found here.

 

If this answers your question, please mark your post as Solved.

 

Scott

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

View solution in original post

2 REPLIES 2
Super User
Super User

Re: Why aren't all my list columns being copied to second list?

@JamesB-NBCC :

 

As far as I know, you cannot update a hyperlink or picture column using "out of the box" Flow actions.  You can get there by using the Send an HTTP request to SharePoint action.

Details and instructions can be found here.

 

If this answers your question, please mark your post as Solved.

 

Scott

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

View solution in original post

JamesB-NBCC
Level: Powered On

Re: Why aren't all my list columns being copied to second list?

Ok thanks. I'll go check ou tthat link!

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors
Users Online
Currently online: 258 members 6,276 guests
Please welcome our newest community members: