cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
misc
Resolver II
Resolver II

WorkflowOperationParametersRuntimeMissingValue. The 'inputs.parameters' of workflow operation 'Delete_a_row_2' of type 'OpenApiConnection' is not valid. Error details: The resolved string values for the following parameters are invalid, they may not be null or empty: 'id'

My flow works. It does everything it should, and yet it keeps telling me that it's failing with the above error. This part of the flow is deleting rows from an excel template to revert it back to empty. 

 

Even weirder, is without any changes, it was working fine the other day, then suddenly it started throwing the error message, despite as I said, everything still working fine; the template is still reverted to blank as it should.

 

flowfailbutnot.png

Any ideas are greatly appreciated!

1 ACCEPTED SOLUTION

Accepted Solutions
Sharuk
Helper IV
Helper IV

Hi @misc , that's good to hear,

this will mostly occurs because of the following scenario

Sharuk_0-1614597165635.png

where there might be empty rows after table header, where as in flow it will throw error while deleting that null value row

 

Sharuk_1-1614597272705.png

 

so either you have to delete that empty row from flow, or add id value 

View solution in original post

6 REPLIES 6
misc
Resolver II
Resolver II

Commenting in the hope of bumping this - I'm still receiving this error

misc
Resolver II
Resolver II

Bumping again as the error still exists and I still haven't found a fix

Sharuk
Helper IV
Helper IV

Hi @misc , this is probably because of having empty rows in your excel file, either you go into excel delete all the empty records from it or add the ID value for each record

misc
Resolver II
Resolver II

It randomly started to work again at the tail end of last week as I decided to go live despite it giving the error (as it was still working). 

 

Still no idea why as nothing has changed. But at least it's not showing as failed any more! 

Sharuk
Helper IV
Helper IV

Hi @misc , that's good to hear,

this will mostly occurs because of the following scenario

Sharuk_0-1614597165635.png

where there might be empty rows after table header, where as in flow it will throw error while deleting that null value row

 

Sharuk_1-1614597272705.png

 

so either you have to delete that empty row from flow, or add id value 

View solution in original post

That would make sense, because I have conditional formatting in place on the table it always puts in its own empty row as extra. If I delete that row the formatting is removed so not an option unfortunately. No worries, it is working now. Thank you.

 

Helpful resources

Announcements
MPA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

R2 (Green) 768 x 460px.png

Microsoft Dynamics 365 & Power Platform User Professionals

DynamicsCon is a FREE, 4 half-day virtual learning experience for 11,000+ Microsoft Business Application users and professionals.

Top Solution Authors
Users online (1,524)