cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
stuartmccoll
New Member

Working with multipart form data from HTTP trigger

Hi,

 

I'm trying to create a Power Automate flow which takes a file from multipart form data received via an HTTP trigger and then creates this file within OneDrive or SharePoint.

 

I've found a few older tutorials online which have enabled me to get to the stage where I can access the multipart form data and convert the base64 encoded version of the file into binary. If I run my Power Automate flow with only these steps, then it runs successfully. However, as soon as I add an extra block to the flow to do anything, I get back an InvalidRequestContext error from the flow.

 

Here's the version of the flow which works:

 

Working version of Power Automate flowWorking version of Power Automate flow

 

The first Compose section has an expression of 'triggerMultipartBody(0)'. The second Compose section has an expression of '

base64ToBinary(triggerMultipartBody(0)['$content'])'.
 
At this point, I add a step to create a file in OneDrive using a dummy file name and the output of the second Compose section.
 
Screenshot of non-working Power Automate flowScreenshot of non-working Power Automate flow

 

The error I receive from this is:

 

{
"error": {
"code": "InvalidRequestContent",
"message": "The input body for trigger 'manual' of type 'Request' must be of type JSON, but was of type 'multipart/form-data; boundary=--------------------------190915140118851309356544'."
}
}
 
I receive this same error message even if I try to create a static file without accessing the output of the second Compose section.
 
I've got a dummy JSON schema in the HTTP request, but the flow generates the same errors with or without this. In terms of the request, I'm sending it from Postman with a 'form-data' body which contains a single PNG file, and haven't changed anything else in Postman other than pasting in the HTTP trigger URL and selecting 'POST' as the HTTP method.
 
Would anybody know what's happening here?
10 REPLIES 10
robertpagano
New Member

Hey there!

 

Just curious if you ever got this to work. I am running into a similar issue.

 

Thanks!

eliz_talent
Helper II
Helper II

Hi!

I had the same problem.

What is more - if I delete the creation of file step - flow run with success.

The solution for me was to call child flow (thru HTTP request) with step to create file.

 

The main reason for the error you get is that trigger "When a HTTP request is received" cannot receive any type but application/json. So in trigger leave JSON Schema empty.

 

eliz_talent_0-1598945241791.png

Untitled.png

The child flow:

Untitled.png

eliz_talent_2-1598945673910.png

 

I'm having the same issue. Can you export the flow? I'm not quit understanding where to put the child flow?

The main flow which I trigger from the button is very simple:Untitled.png

The last step is to send a request to child flow.

In URI you should specify the URI from the trigger of the child flow.

The Body:

{
"content": "@{triggerMultipartBody(0)['$content']}"
}

Update: Eliz you're a genius! It worked , all the kudos to you!

Hi I can't get this to work. Can you please look over to help?

I am getting a mismatch type error for string and object. This is how my http call to child looks.

kmin_0-1610335167659.png

Child flow:

 

kmin_1-1610335244333.png

 

Can you look over the issue that i am still having with this?  I feel like i have tried to duplicate but still getting a type mismatch error from the child flow. 

Hi @kmin !

It looks like you forgot to add curly brackets in the body when calling a child flow :

{

"content":"..."

}

Hi, I did forget the brackets but added it in but gets the same error message below. I am triggering this from postman using an .jpg file in the body. The JSON schema in the child i copied from this post. If i change the 'object' to 'string' there, i get over this error but fails in 1st in the child.

 

"The input body for trigger 'manual' of type 'Request' did not match its schema definition. Error details: 'Invalid type. Expected String but got Object.'. "

 

SteepM
Frequent Visitor

I have the same issue! With empty JSON Schema, I am getting "

The input body for trigger 'manual' of type 'Request' must be of type JSON, but was of type 'multipart/form-data;", I am trying exactly as shown https://www.youtube.com/watch?v=wJj0E1C4z0c&ab_channel=Dave%27sTechTips
With .pdf file

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Top Kudoed Authors
Users online (49,882)