cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

Wrong URL while testing custom API?

Hello,

 

I'm attempting to make a custom connector to test an OpenApi spec.. and when I hit "Test Operation" in the custom connector editor.. it fails.  I'm assuming it's failing because the URL it's making the request to is not the one I specified.  Instead it's base URL is "https://msmanaged-na.azure-apim.net/apim/openapitest.5fad143f79cb399d83.5f902c56b1c595e4a0/766b36eb-..." instead of my own host URL which I entered under the 'General' tab while creating this connector.

 

Is there something I missed? or does Flow have restrictions on what URLs are allowed?

 

Thanks,

- Jeff

3 REPLIES 3
Highlighted
New Member

Re: Wrong URL while testing custom API?

Nevermind, it's now working (without changing anything)? Might have taken a while to "register" or something?

Highlighted
Community Support
Community Support

Re: Wrong URL while testing custom API?

Hi @JRhatigan,

 

Have you solved your problem?

Which authentication do you use within your custom connector?

 

The Request area display information based on the HTTP request that's included in the OpenAPI definition. More details about reviewing the connector definition, please check the following article:

Review the connector definition

 

If you use API key authentication within your custom connector, it is not recommended to test the connector immediately after you create your custom connector, it can take a few minutes until the connector is ready to connect to the API.

 

More details about testing connector, please check the following article:

Test Connector

 

Best regards,

Kris

 

 

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Microsoft
Microsoft

Re: Wrong URL while testing custom API?

Hi @v-xida-msft

 

I am using OAuth 2.0 authentication and I can see that the redirect URL being fetched is incorrect. I am unable to connect to my service because of that.

 

Please help

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

Join the new Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (7,006)