cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Post Patron
Post Patron

Wrong user emailed when data captured from Microsoft Forms

I have discovered an unexpected issue with using a flow that captures data submitted via MS Forms and add its to SharePoint - when my flow send an email to the person that filled out the data in forms, I receive the email and it is displayed under my personal view in SharePoint rather than the test user account I sent it from. I have another flow where if I email an email address from this same test account then that account receives the email confirming its been logged in SharePoint so Im thinking because Im the one who designed the form in MS Forms, the flow thinks I am the one filling it out even though its been shared for others to submit data to. I can verify that the test user account does appear in the forms responses excel spreadsheet so Its obviously somewhere in flow its not happy - check my screenshots - any ideas?

 

Screenshot 2019-12-07 at 18.28.14.pngScreenshot 2019-12-07 at 18.28.40.pngScreenshot 2019-12-07 at 18.28.58.pngScreenshot 2019-12-07 at 18.29.16.pngScreenshot 2019-12-07 at 18.29.36.pngScreenshot 2019-12-07 at 18.29.53.png

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @sudosaurus ,

 

Have you create a new flow and make the test again?

 

Best regards,

Alice       

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

5 REPLIES 5
Super User III
Super User III

Hi @sudosaurus

 

What's your send email connection credentials? Is that your test account?



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog

Power Automate Video Tutorials

The send connector is for my account - the same account that created the form and the power automate flow!

 

When the item is created in SharePoint it is supposed to populate the Requester field however it is not doing this from the Forms flow. But is doing it from my shared mailbox to Sharepoint flow. Which leaves me to think I need to use a Responders Email claim and map it to the Requester field - would that solve the issue?

EDIT: I tried this by adding another Requester field and the test account is populated in that one but my own account is still populated in the original.

 

It seems that when a form is responded to when the flow captures the data it thinks its coming from my account.

Therefore Im not sure that Forms is the best method to use here and maybe I should just use a SharePoint form or PowerApps instead.

Hi @sudosaurus 

 

Forms should give you the respondents email address. This way you should know who submitted the form data is.



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog

Power Automate Video Tutorials

Ill have to maybe re-create the flow and see if it works second time around.

Hi @sudosaurus ,

 

Have you create a new flow and make the test again?

 

Best regards,

Alice       

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Microsoft Ignite

Microsoft Power Platform: 2021 Release Wave 1 Plan

Power Platform release plan for the 2021 release wave 1 describes all new features releasing from April through September 2021.

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (31,094)