cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ChriBusc1
New Member

action in condition checking for empty value doesn´t get executed

Hi all,

 

I´m trying to build a flow that compares a table within Excel with a SharePoint list and adds missing entries to the SharePoint list.

To do so I get all entries from Excel and check for every entry via the title whether the entry is existing in the SharePoint list. The result is empty or the title. A condition checks this value and shall create a new entry when the result is empty. Unfortunately, it doesn´t work like expected.

When the result is empty the actions don´t get executed. Only when the value isn´t empty, actions get executed.

As the condition I use "current item equals null" but also tried other conditions like "length of current item equals 0" or "empty (current item) equals true".

In the execution history I get no error but can see the hint “not specified” for the condition of items where the result is empty.

Do you have any idea, what I´m doing wrong?

 

Thanks

Christopher

1 ACCEPTED SOLUTION

Accepted Solutions
v-alzhan-msft
Community Support
Community Support

Hi @ChriBusc1 ,

 

Could you please share a screenshot of the configuration of your flow?

You should create the flow as below:

1.png

length(body('Filter_array'))

 

Best regards,

Alice   

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
v-alzhan-msft
Community Support
Community Support

Hi @ChriBusc1 ,

 

Could you please share a screenshot of the configuration of your flow?

You should create the flow as below:

1.png

length(body('Filter_array'))

 

Best regards,

Alice   

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Hi @v-alzhan-msft,

 

thank you very much, now it works like it´s supposed to.

Instead of using "Filter array" I used the filter option within "Get items" and placed "Get items" within "Apply to each". Seems like this was the mistake.

 

Best regards,

Christopher

Helpful resources

Announcements
2022 Release Wave 1 760x460.png

2022 Release Wave 1 Plan

Power Platform release plan for the 2022 release wave 1 describes all new features releasing from April 2022 through September 2022.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Solution Authors
Top Kudoed Authors
Users online (2,308)