cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Perez
Helper V
Helper V

append to string not considering all values

Hi,

i have a multi coice field called 'ProductDomain' in a SPO list, im trying to append it to one string so i can send it in a mail.

when i tested it on a record with more than 2 products selected it is only appending the first two values and ignore the rest.

i tried to implemnent using append to string and append to array with same results, solution as described in the links attached:

  1. append to string
  2. Append to array

in the screenshots below you can see that all the items are returend by the get items activity.

only values returned are SOM, USM

image.png

not sure why its happened, any ideas?

 

thanks,

Eyal

1 ACCEPTED SOLUTION

Accepted Solutions

 

Hi @Perez ,

 

Even if I configure item()['Value'] to Append to string variable action, I could not reproduce the same issue.

Please try to fill Product Domain Value in Append to string variable action.

51.PNG

Besides, I noticed that you are using Get items action, then the String variable will record the Product Domain Value contained in all eligible items, hope it makes sense.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

4 REPLIES 4
v-bacao-msft
Community Support
Community Support

 

Hi @Perez ,

 

Could you provide the screenshot of the Flow configuration?

I have made a test on my side and Append to array variable/ Append to string variable action all work as expected.

46.PNG

Have you configured some conditions to filter elements?

 

Please provide more details so that we could do further analysis.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Perez
Helper V
Helper V

Hi @v-bacao-msft , thanks for your reply.

dont have any filter in my flow.

  1. im getting the items from the SPO list
  2. checking set of condition
  3. if eveluated true than the apply to each with append to string activity should be executed.

screenshot

image.pngimage.pngimage.png

 

Hi @Perez ,

 

Even if I configure item()['Value'] to Append to string variable action, I could not reproduce the same issue.

Please try to fill Product Domain Value in Append to string variable action.

51.PNG

Besides, I noticed that you are using Get items action, then the String variable will record the Product Domain Value contained in all eligible items, hope it makes sense.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Perez
Helper V
Helper V

@v-bacao-msft  thanks a lot it worked!

Helpful resources

Announcements
MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Power automate tips 768x460 v2.png

Restore a Deleted Flow

Did you know that you could restore a deleted flow? Check out this helpful article.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

Users online (3,275)